goffice: fix packaging
authorKoen Kooi <koen@openembedded.org>
Thu, 29 Oct 2009 10:21:56 +0000 (11:21 +0100)
committerKoen Kooi <koen@openembedded.org>
Thu, 29 Oct 2009 10:21:56 +0000 (11:21 +0100)
recipes/gnome/goffice_0.7.14.bb

index 9fff0b4..77dd39a 100644 (file)
@@ -1,9 +1,9 @@
 DESCRIPTION="Gnome Office Library"
 LICENSE="GPLv2"
 
-DEPENDS="glib-2.0 gtk+ pango cairo libgnomeprint libgsf libglade libpcre libxml2 libart-lgpl"
+PR = "r1"
 
-FILES_${PN}-dbg += "${libdir}/goffice/${PV}/plugins/*/.debug"
+DEPENDS="glib-2.0 gtk+ pango cairo libgnomeprint libgsf libglade libpcre libxml2 libart-lgpl"
 
 inherit gnome pkgconfig
 
@@ -11,10 +11,33 @@ do_stage() {
        autotools_stage_all
 }
 
+FILES_${PN}-dbg += "${libdir}/goffice/${PV}/plugins/*/.debug"
+
+RRECOMMENDS_${PN} = " \
+  goffice-plugin-plot-barcol \
+  goffice-plugin-plot-distrib \
+  goffice-plugin-plot-pie \
+  goffice-plugin-plot-radar \
+  goffice-plugin-plot-surface \
+  goffice-plugin-plot-xy \
+  goffice-plugin-reg-linear \
+  goffice-plugin-reg-logfit \
+  goffice-plugin-smoothing \
+"
+
+FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} \
+            ${sysconfdir} ${sharedstatedir} ${localstatedir} \
+            ${base_bindir}/* ${base_sbindir}/* \
+            ${base_libdir}/*${SOLIBS} \
+            ${datadir}/${PN} \
+            ${datadir}/pixmaps ${datadir}/applications \
+            ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
+            ${libdir}/bonobo/servers"
+
 PACKAGES_DYNAMIC = "goffice-plugin-*"
 
 python populate_packages_prepend () {
-        goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins', d)
+        goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins/', d)
 
         do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
 }