libgcrypt: update to 1.4.6
authorGrazvydas Ignotas <notasas@gmail.com>
Sat, 21 Oct 2017 17:09:32 +0000 (20:09 +0300)
committerGrazvydas Ignotas <notasas@gmail.com>
Sat, 21 Oct 2017 20:19:34 +0000 (23:19 +0300)
for gnutls-2.12.24

recipes/libgcrypt/files/add-pkgconfig-support.patch
recipes/libgcrypt/libgcrypt.inc
recipes/libgcrypt/libgcrypt_1.4.6.bb [new file with mode: 0644]

index 9b00e82..3e33679 100644 (file)
@@ -1,17 +1,21 @@
-diff -Nur libgcrypt-1.2.4/configure.ac libgcrypt11-1.2.4/configure.ac
---- libgcrypt-1.2.4/configure.ac 2007-02-01 19:41:06.000000000 +0100
-+++ libgcrypt11-1.2.4/configure.ac 2007-02-11 13:05:36.000000000 +0100
-@@ -808,6 +808,7 @@
+Upstream-Status: Inappropriate [distribution]
+
+Index: libgcrypt-1.2.4/configure.ac
+===================================================================
+--- libgcrypt-1.2.4.orig/configure.ac  2008-03-19 22:14:50.000000000 +0000
++++ libgcrypt-1.2.4/configure.ac       2008-03-19 22:14:58.000000000 +0000
+@@ -807,6 +807,7 @@
+ doc/Makefile
  src/Makefile
  src/gcrypt.h
- src/libgcrypt-config
 +src/libgcrypt.pc
+ src/libgcrypt-config
  tests/Makefile
  w32-dll/Makefile
- ])
-diff -Nur libgcrypt-1.2.4/src/libgcrypt.pc.in libgcrypt11-1.2.4/src/libgcrypt.pc.in
---- libgcrypt-1.2.4/src/libgcrypt.pc.in 1970-01-01 01:00:00.000000000 +0100
-+++ libgcrypt11-1.2.4/src/libgcrypt.pc.in 2007-02-11 13:03:30.000000000 +0100
+Index: libgcrypt-1.2.4/src/libgcrypt.pc.in
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ libgcrypt-1.2.4/src/libgcrypt.pc.in        2008-03-19 22:14:58.000000000 +0000
 @@ -0,0 +1,32 @@
 +# Process this file with autoconf to produce a pkg-config metadata file.
 +# Copyright (C) 2002, 2003, 2004, 2005, 2006 Free Software Foundation
@@ -42,21 +46,6 @@ diff -Nur libgcrypt-1.2.4/src/libgcrypt.pc.in libgcrypt11-1.2.4/src/libgcrypt.pc
 +Description: GNU crypto library
 +URL: http://www.gnupg.org
 +Version: @VERSION@
-+Libs: -L${libdir} @LIBGCRYPT_CONFIG_LIBS@
-+Libs.private: @GPG_ERROR_LIBS@
-+Cflags: -I${includedir} @LIBGCRYPT_CONFIG_CFLAGS@ @GPG_ERROR_CFLAGS@
-diff -Nur libgcrypt-1.2.4/src/Makefile.am libgcrypt11-1.2.4/src/Makefile.am
---- libgcrypt-1.2.4/src/Makefile.am 2006-11-30 16:38:18.000000000 +0100
-+++ libgcrypt11-1.2.4/src/Makefile.am 2007-02-11 13:10:03.000000000 +0100
-@@ -27,6 +27,11 @@
- lib_LTLIBRARIES = libgcrypt.la
-+# Pkg-config script.
-+pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfig_DATA = libgcrypt.pc
-+DISTCLEANFILES = $(pkgconfig_DATA)
-+
- if HAVE_LD_VERSION_SCRIPT
-   libgcrypt_version_script_cmd = -Wl,--version-script=$(srcdir)/libgcrypt.vers
- else 
++Libs: -L${libdir} -lgcrypt
++Libs.private: -L${libdir} -lgpg-error
++Cflags: -I${includedir} 
index 77dd1d9..8665775 100644 (file)
@@ -1,22 +1,30 @@
 DESCRIPTION = "A general purpose cryptographic library based on the code from GnuPG"
+HOMEPAGE = "http://directory.fsf.org/project/libgcrypt/"
+BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
 SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "GPL LGPL FDL"
+
+# helper program gcryptrnd and getrandom are under GPL, rest LGPL
+LICENSE = "GPLv2+ LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+                    file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff"
+
 DEPENDS = "libgpg-error"
 
 SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-${PV}.tar.gz \
-           file://add-pkgconfig-support.patch;patch=1 \
-           file://mips-h-constraint.patch;patch=1"
+           file://add-pkgconfig-support.patch;patch=1"
 
-inherit autotools binconfig pkgconfig lib_package
+inherit autotools binconfig pkgconfig
 
 EXTRA_OECONF = "--without-pth --disable-asm --with-capabilities"
 
-ARM_INSTRUCTION_SET = "arm"
-
+# libgcrypt.pc is added locally and thus installed here
 do_install_append() {
-       install -d ${D}/${libdir}/pkgconfig/
-       cp ${S}/src/*.pc ${D}/${libdir}/pkgconfig/
+       install -d ${D}/${libdir}/pkgconfig
+       install -m 0644 ${S}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/
 }
 
-BBCLASSEXTEND = "native"
+ARM_INSTRUCTION_SET = "arm"
+
+# move libgcrypt-config into -dev package
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir} ${libdir}/pkgconfig/*.pc"
diff --git a/recipes/libgcrypt/libgcrypt_1.4.6.bb b/recipes/libgcrypt/libgcrypt_1.4.6.bb
new file mode 100644 (file)
index 0000000..aef616c
--- /dev/null
@@ -0,0 +1,6 @@
+require libgcrypt.inc
+
+PR = "r1"
+
+SRC_URI[md5sum] = "bfd45922eefb8a24d598af77366220d4"
+SRC_URI[sha256sum] = "996d2874643318c9df835777034a8b7a923d3cd0bee593bab1780305f9de872d"