di: new recipe
authorThomas Zimmermann <ml@vdm-design.de>
Sat, 28 Nov 2009 08:01:33 +0000 (08:01 +0000)
committerKlaus Kurzmann <mok@fluxnetz.de>
Sat, 28 Nov 2009 09:20:48 +0000 (10:20 +0100)
* add di (disk info)
* add di to task-shr-feed
* this solves SHR bug #501

Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
conf/checksums.ini
recipes/di/di_4.17.bb [new file with mode: 0644]
recipes/tasks/task-shr-feed.bb

index b6369df..fdeeb5b 100644 (file)
@@ -5290,6 +5290,10 @@ sha256=eb20cb028176e52432a2b877b2e292100dc41b384e829bc9e6d4823075ed8188
 md5=dd627a121e43835bead3ffef5b1a72fd
 sha256=f435e14e1f54dc8792f4e655463d07f2bdbe6d8a8581bd62f5167334ab18bb87
 
+[http://www.gentoo.com/di/di-4.17.tar.gz]
+md5=be55b3a1693b318effa3db8d1c0243c1
+sha256=46e124670fb2b63cb7500a8b36b7856c15858cb35658263ddad4933935d5e210
+
 [ftp://ftp.gnome.org/pub/gnome/sources/dia/0.95/dia-0.95-pre3.tar.gz]
 md5=642f7e7d4c71dc144b60f51f9d65de62
 sha256=902da1b1e9d90dfda8aa1864846db8ad12386e7521fc9f8b18c8ba220dd0123a
diff --git a/recipes/di/di_4.17.bb b/recipes/di/di_4.17.bb
new file mode 100644 (file)
index 0000000..9b04df8
--- /dev/null
@@ -0,0 +1,17 @@
+DESCRIPTION = "di is a disk information utility, displaying everything (and more) that your df(1) command does. It features the ability to display your disk usage in whatever format you desire/prefer/are used to. It is designed to be portable across many platforms. "
+HOMEPAGE = "http://www.gentoo.com/di/"
+LICENSE = "MIT-style"
+SECTION = "base"
+DEPENDS = "perl-native"
+
+SRC_URI = "http://www.gentoo.com/di/di-${PV}.tar.gz"
+
+do_install() {
+       # install binary
+       install -d ${D}${bindir}
+       install -m 0755 ${S}/di ${D}${bindir}
+
+       # install manpage
+       install -d ${D}${mandir}/man1
+       install -m 0644 ${S}/di.1 ${D}${mandir}/man1
+}
index 209c644..4dba7ca 100644 (file)
@@ -7,6 +7,7 @@ inherit task
 
 RDEPENDS_${PN} += "\
                babiloo-efl \
+               di \
                dictator \
                dosbox \
                enotes \