Move stage-manager-* into bin/ rather than a recipe
authorChris Larson <chris_larson@mentor.com>
Thu, 28 Oct 2010 00:29:52 +0000 (17:29 -0700)
committerChris Larson <chris_larson@mentor.com>
Wed, 26 Jan 2011 21:28:29 +0000 (14:28 -0700)
Signed-off-by: Chris Larson <chris_larson@mentor.com>
Acked-by: Khem Raj <raj.khem@gmail.com>
Acked-by: Eric BĂ©nard <eric@eukrea.com>
bin/stage-manager [moved from recipes/stage-manager/files/stage-manager with 99% similarity]
bin/stage-manager-opkg [moved from recipes/stage-manager/files/stage-manager-opkg with 100% similarity]
bin/stage-manager-opkg-build [moved from recipes/stage-manager/files/stage-manager-opkg-build with 100% similarity]
classes/base.bbclass
classes/packaged-staging.bbclass
recipes/stage-manager/stagemanager-native_0.0.1.bb [deleted file]

similarity index 99%
rename from recipes/stage-manager/files/stage-manager
rename to bin/stage-manager
index 4fc112d..a7131c6 100755 (executable)
@@ -151,6 +151,3 @@ if __name__ == "__main__":
     if found_difference:
         sys.exit(5)
     sys.exit(0)
-
-
-
index 25d72d4..fdffcfa 100644 (file)
@@ -63,8 +63,7 @@ def base_deps(d):
        # that case though.
        #
        deps = "coreutils-native"
-       if bb.data.getVar('PN', d, True) in ("shasum-native", "stagemanager-native",
-                                            "coreutils-native"):
+       if bb.data.getVar('PN', d, True) in ("shasum-native", "coreutils-native"):
                deps = ""
 
        # INHIBIT_DEFAULT_DEPS doesn't apply to the patch command.  Whether or  not
@@ -78,7 +77,7 @@ def base_deps(d):
                                bb.data.getVar('PN', d, True) not in \
                                ("linux-libc-headers-native", "quilt-native",
                                 "unifdef-native", "shasum-native",
-                                "stagemanager-native", "coreutils-native"):
+                                "coreutils-native"):
                        deps += " linux-libc-headers-native"
        return deps
 
index f217aee..b3a1640 100644 (file)
@@ -23,7 +23,6 @@ PSTAGE_SCAN_CMD ?= "find ${PSTAGE_TMPDIR_STAGE} \( -name "*.la" -o -name "*-conf
 
 PSTAGE_NATIVEDEPENDS = "\
     shasum-native \
-    stagemanager-native \
     "
 
 BB_STAMP_WHITELIST = "${PSTAGE_NATIVEDEPENDS}"
@@ -75,10 +74,6 @@ python __anonymous() {
     # Add task dependencies if we're active, otherwise mark packaged staging
     # as inactive.
     if pstage_allowed:
-        deps = bb.data.getVarFlag('do_setscene', 'depends', d) or ""
-        deps += " stagemanager-native:do_populate_sysroot"
-        bb.data.setVarFlag('do_setscene', 'depends', deps, d)
-
         policy = bb.data.getVar("BB_STAMP_POLICY", d, True)
         if policy == "whitelist" or policy == "full":
            deps = bb.data.getVarFlag('do_setscene', 'recrdeptask', d) or ""
diff --git a/recipes/stage-manager/stagemanager-native_0.0.1.bb b/recipes/stage-manager/stagemanager-native_0.0.1.bb
deleted file mode 100644 (file)
index 8ad73ef..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-DESCRIPTION = "Helper script for packaged-staging.bbclass"
-PR = "r15"
-
-SRC_URI = "file://stage-manager \
-           file://stage-manager-opkg \
-           file://stage-manager-opkg-build "
-LICENSE = "GPLv2"
-
-PACKAGE_ARCH = "all"
-
-inherit native
-
-DEPENDS = " "
-PACKAGE_DEPENDS = " "
-PATCHDEPENDENCY = ""
-INHIBIT_DEFAULT_DEPS = "1"
-
-PSTAGING_DISABLED = "1"
-
-NATIVE_INSTALL_WORKS = "1"
-do_install() {
-       install -d ${STAGING_BINDIR}
-       install -m 0755 ${WORKDIR}/stage-manager ${STAGING_BINDIR}
-       install -m 0755 ${WORKDIR}/stage-manager-opkg ${STAGING_BINDIR}
-       install -m 0755 ${WORKDIR}/stage-manager-opkg-build ${STAGING_BINDIR}
-}