base-files: Add base files for the omap3-pandora.
authorDavid-John Willis <John.Willis@Distant-earth.com>
Wed, 28 Oct 2009 09:09:32 +0000 (09:09 +0000)
committerKoen Kooi <koen@openembedded.org>
Wed, 28 Oct 2009 09:16:31 +0000 (10:16 +0100)
recipes/base-files/base-files/omap3-pandora/fstab [new file with mode: 0644]
recipes/base-files/base-files/omap3-pandora/profile [new file with mode: 0644]
recipes/base-files/base-files_3.0.14.bb

diff --git a/recipes/base-files/base-files/omap3-pandora/fstab b/recipes/base-files/base-files/omap3-pandora/fstab
new file mode 100644 (file)
index 0000000..a4c8610
--- /dev/null
@@ -0,0 +1,13 @@
+# stock fstab - you probably want to override this with a machine specific one
+
+rootfs               /                    auto       defaults,noatime      1  1
+proc                 /proc                proc       defaults              0  0
+devpts               /dev/pts             devpts     mode=0620,gid=5       0  0
+usbfs                /proc/bus/usb        usbfs      defaults              0  0
+tmpfs                /var/volatile        tmpfs      defaults              0  0
+tmpfs                /dev/shm             tmpfs      mode=0777             0  0
+tmpfs                /media/ram           tmpfs      defaults              0  0
+
+# uncomment this if your device has a SD/MMC/Transflash slot
+#/dev/mmcblk0p1       /media/card          auto       defaults,sync,noauto  0  0
+
diff --git a/recipes/base-files/base-files/omap3-pandora/profile b/recipes/base-files/base-files/omap3-pandora/profile
new file mode 100644 (file)
index 0000000..5797535
--- /dev/null
@@ -0,0 +1,34 @@
+# /etc/profile: system-wide .profile file for the Bourne shell (sh(1))
+# and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).
+
+PATH="/usr/local/bin:/usr/bin:/bin"
+EDITOR="/bin/vi"                       # needed for packages like cron
+test -z "$TERM" && TERM="vt100"        # Basic terminal capab. For screen etc.
+
+if [ ! -e /etc/localtime ]; then
+       TZ="UTC"                # Time Zone. Look at http://theory.uwinnipeg.ca/gnu/glibc/libc_303.html 
+                               # for an explanation of how to set this to your local timezone.
+       export TZ
+fi
+
+if [ "`id -u`" -eq 0 ]; then
+   PATH=$PATH:/usr/local/sbin:/usr/sbin:/sbin:
+fi
+if [ "$PS1" ]; then
+# works for bash and ash (no other shells known to be in use here)
+   PS1='\u@\h:\w\$ '
+fi
+
+if [ -d /etc/profile.d ]; then
+  for i in /etc/profile.d/*.sh; do
+    if [ -r $i ]; then
+      . $i
+    fi
+  done
+  unset i
+fi
+
+export PATH PS1 OPIEDIR QPEDIR QTDIR EDITOR TERM
+
+umask 022
+
index 5e78797..483aef7 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Miscellaneous files for the base system."
 SECTION = "base"
 PRIORITY = "required"
-PR = "r88"
+PR = "r89"
 LICENSE = "GPL"
 
 SRC_URI = " \