classes
authorRaymond Danks <raymond@edanks.com>
Wed, 31 May 2006 21:59:26 +0000 (21:59 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Wed, 31 May 2006 21:59:26 +0000 (21:59 +0000)
  bootimg.bbclass - This creates a bootable image using syslinux, your kernel and an optional initrd
  kernel.bbclass - drivers/crypto and include/acpi are needed by some
  pkgconfig.bbclass - searching for .pc files
  syslinux.bbclass - This creates a configuration file suitable for use with syslinux.
site
  mipsel-linux, i486-linux, i686-linux, x86_64-linux updates for:
       gcc, lmbench, X11R7.0, sudo, audacity
conf
  add db1200 and geodelx machine configurations.

classes/kernel.bbclass
classes/pkgconfig.bbclass
site/i486-linux
site/i686-linux
site/mipsel-linux
site/x86_64-linux

index ad51c4e..502a2a6 100644 (file)
@@ -109,6 +109,16 @@ kernel_do_stage() {
        mkdir -p ${STAGING_KERNEL_DIR}/include/pcmcia
        cp -fR include/pcmcia/* ${STAGING_KERNEL_DIR}/include/pcmcia/
 
+       if [ -d drivers/crypto ]; then
+               mkdir -p ${STAGING_KERNEL_DIR}/drivers/crypto
+               cp -fR drivers/crypto/* ${STAGING_KERNEL_DIR}/drivers/crypto/
+       fi
+
+       if [ -d include/acpi ]; then
+               mkdir -p ${STAGING_KERNEL_DIR}/include/acpi
+               cp -fR include/acpi/* ${STAGING_KERNEL_DIR}/include/acpi/
+       fi
+
        if [ -d include/sound ]; then
                mkdir -p ${STAGING_KERNEL_DIR}/include/sound
                cp -fR include/sound/* ${STAGING_KERNEL_DIR}/include/sound/
@@ -133,7 +143,7 @@ kernel_do_stage() {
        # Check if arch/${ARCH}/Makefile exists and install it
        if [ -e arch/${ARCH}/Makefile ]; then
                install -d ${STAGING_KERNEL_DIR}/arch/${ARCH}
-               install -m 0644 arch/${ARCH}/Makefile ${STAGING_KERNEL_DIR}/arch/${ARCH}
+               install -m 0644 arch/${ARCH}/Makefile* ${STAGING_KERNEL_DIR}/arch/${ARCH}
        fi
        cp -fR include/config* ${STAGING_KERNEL_DIR}/include/   
        install -m 0644 ${KERNEL_OUTPUT} ${STAGING_KERNEL_DIR}/${KERNEL_IMAGETYPE}
index 62f15f3..f2054b0 100644 (file)
@@ -20,7 +20,7 @@ def get_pkgconfig_mangle(d):
        return s
 
 do_stage_append () {
-       for pc in `find ${S} -name '*.pc' | grep -v -- '-uninstalled.pc$'`; do
+       for pc in `find ${S} -name '*.pc' -type f | grep -v -- '-uninstalled.pc$'`; do
                pcname=`basename $pc`
                install -d ${PKG_CONFIG_PATH}
                cat $pc | sed ${@get_pkgconfig_mangle(d)} > ${PKG_CONFIG_PATH}/$pcname
index 5ead29b..1791e58 100644 (file)
@@ -51,6 +51,7 @@ glib_cv_uscore=${glib_cv_uscore=no}
 glib_cv___va_copy=${glib_cv___va_copy=yes}
 glib_cv_va_copy=${glib_cv_va_copy=yes}
 glib_cv_va_val_copy=${glib_cv_va_val_copy=yes}
+glib_cv_rtldglobal_broken=${glib_cv_rtldglobal_broken=yes}
 
 # glib-2.0
 glib_cv_stack_grows=${glib_cv_stack_grows=no}
@@ -60,7 +61,7 @@ glib_cv_use_pid_surrogate=${glib_cv_use_pid_surrogate=yes}
 
 # jikes-native
 ac_cv_sizeof_wchar_t=4
--
+
 # startup-notification
 lf_cv_sane_realloc=yes
 
@@ -129,3 +130,13 @@ am_cv_func_working_getline=${am_cv_func_working_getline=yes}
 
 # intercom
 ac_cv_func_fnmatch_works=yes
+
+#sudo
+sudo_cv_uid_t_len=${sudo_cv_uid_t_len=10}
+
+#audacity
+ac_cv_file_lib_src_libmad_frame_h=${ac_cv_file_lib_src_libmad_frame_h=no}
+
+# xorg X11R7
+ac_cv_sys_linker_h=${ac_cv_sys_linker_h=no}
+ac_cv_file__usr_share_X11_sgml_defs_ent=${ac_cv_file__usr_share_X11_sgml_defs_ent=no}
index f5915e8..113929a 100644 (file)
@@ -52,6 +52,7 @@ glib_cv_uscore=${glib_cv_uscore=no}
 glib_cv___va_copy=${glib_cv___va_copy=yes}
 glib_cv_va_copy=${glib_cv_va_copy=yes}
 glib_cv_va_val_copy=${glib_cv_va_val_copy=yes}
+glib_cv_rtldglobal_broken=${glib_cv_rtldglobal_broken=yes}
 utils_cv_sys_open_max=${utils_cv_sys_open_max=1015}
 
 # glib-2.0
@@ -197,3 +198,7 @@ with_broken_putenv=${with_broken_putenv=no}
 
 # xffm
 jm_cv_func_working_readdir=yes
+
+#xserver-xorg
+ac_cv_sys_linker_h=${ac_cv_sys_linker_h=no}
+ac_cv_file__usr_share_X11_sgml_defs_ent=${ac_cv_file__usr_share_X11_sgml_defs_ent=no}
index fe0ee88..7f77695 100644 (file)
@@ -114,3 +114,6 @@ sudo_cv_uid_t_len=${sudo_cv_uid_t_len=10}
 
 #intercom
 ac_cv_func_fnmatch_works=${ac_cv_func_fnmatch_works=yes}
+
+#lmbench
+ac_cv_uint=${ac_cv_unit=yes}
index ba60564..dc7cb09 100644 (file)
@@ -78,3 +78,6 @@ utils_cv_sys_open_max=${utils_cv_sys_open_max=1015}
 
 # gettext
 am_cv_func_working_getline=${am_cv_func_working_getline=yes}
+
+#gcc
+ac_cv_lib_m_sin=${ac_cv_lib_m_sin=yes}