enchant: use more sensible FILES
authorPhil Blundell <philb@gnu.org>
Sat, 13 Jun 2009 08:40:10 +0000 (09:40 +0100)
committerPhil Blundell <philb@gnu.org>
Sat, 13 Jun 2009 08:40:10 +0000 (09:40 +0100)
recipes/enchant/enchant_1.3.0.bb

index cceceeb..85e6297 100644 (file)
@@ -7,7 +7,7 @@ RDEPENDS    = "aspell"
 
 inherit autotools pkgconfig
 
-PR = "r0"
+PR = "r1"
 
 S = "${WORKDIR}/enchant-${PV}"
 
@@ -15,9 +15,10 @@ SRC_URI = "http://www.abisource.com/downloads/enchant/${PV}/enchant-${PV}.tar.gz
 
 EXTRA_OECONF = "--with-aspell-prefix=${STAGING_DIR_HOST}${layout_prefix} --enable-aspell --disable-binreloc"
 
-export CXXFLAGS += " -L${STAGING_LIBDIR} -lstdc++ "
+FILES_${PN} = "${bindir} ${libdir}/*${SOLIBS} ${datadir}/${PN} ${libdir}/${PN}/*.so"
+FILES_${PN}-dev += "${libdir}/${PN}/*{SOLIBSDEV} ${libdir}/${PN}/*.la ${libdir}/${PN}/*.a" 
 
-FILES_${PN} = "/usr/bin/* /usr/lib/enchant/*.so /usr/share/enchant /usr/lib/libenchant*.so.*"
+export CXXFLAGS += " -L${STAGING_LIBDIR} -lstdc++ "
 
 do_stage() {
        autotools_stage_all