gtk+: remove special-casing for native installation, declare provider for gdk-pixbuf...
authorPhil Blundell <philb@gnu.org>
Tue, 9 Mar 2010 20:38:16 +0000 (20:38 +0000)
committerPhil Blundell <philb@gnu.org>
Tue, 9 Mar 2010 20:38:16 +0000 (20:38 +0000)
(based on original patch from Graeme Gregory <dp@xora.org.uk> with minor edits)

recipes/gtk+/gtk+.inc
recipes/gtk+/gtk+_2.18.6.bb

index e6a0684..268657b 100644 (file)
@@ -5,7 +5,7 @@ SECTION = "libs"
 LICENSE = "LGPL"
 PRIORITY = "optional"
 DEPENDS = "glib-2.0 tiff pango atk jpeg libpng libxext libxcursor gtk-doc libgcrypt cups \
-          libxrandr libxdamage libxrender libxcomposite cairo jasper"
+          libxrandr libxdamage libxrender libxcomposite cairo jasper gtk+-native"
 PROVIDES = "gdk-pixbuf"
 
 MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
index 9321b43..8546591 100644 (file)
@@ -8,20 +8,14 @@ PR = "${INC_PR}.3"
 BBCLASSEXTEND = "native"
 
 DEPENDS_virtclass-native = "libpng-native atk-native pango-native cairo-native libxrender-native"
+PROVIDES_virtclass-native = "gdk-pixbuf-csource-native"
 
 # Enable xkb selectively
 XKBTOGGLE = " --disable-xkb"
 XKBTOGGLE_angstrom = ""
 
 EXTRA_OECONF = "--with-libtiff ${XKBTOGGLE} --disable-glibtest gio_can_sniff=yes"
-EXTRA_OECONF_append_virtclass-native = " --without-libtiff --without-libjpeg --disable-modules"
-
-do_install_virtclass-native () {
-       autotools_do_install
-       find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \;
-       rm ${D}${bindir}/gdk-pixbuf-csource
-       echo "going native!"
-}
+EXTRA_OECONF_append_virtclass-native = " --without-libtiff --without-libjpeg"
 
 PACKAGES_DYNAMIC = "gtk-module-* gdk-pixbuf-loader-* gtk-immodule-* gtk-printbackend-*"