ipkg: remove a couple of outdated ones, update is_processing patch courtesy OpenMoko...
authorMichael Lauer <mickey@vanille-media.de>
Mon, 2 Apr 2007 14:33:21 +0000 (14:33 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Mon, 2 Apr 2007 14:33:21 +0000 (14:33 +0000)
15 files changed:
packages/ipkg/files/is-processing.patch
packages/ipkg/ipkg-0.99.153/.mtn2git_empty [deleted file]
packages/ipkg/ipkg-0.99.153/fix-bug1393.patch [deleted file]
packages/ipkg/ipkg-0.99.155/.mtn2git_empty [deleted file]
packages/ipkg/ipkg-0.99.155/upgrade-message-garbage.patch [deleted file]
packages/ipkg/ipkg-native_0.99.152.bb [deleted file]
packages/ipkg/ipkg-native_0.99.153.bb [deleted file]
packages/ipkg/ipkg-native_0.99.154.bb [deleted file]
packages/ipkg/ipkg-native_0.99.159.bb [deleted file]
packages/ipkg/ipkg_0.99.152.bb [deleted file]
packages/ipkg/ipkg_0.99.153.bb [deleted file]
packages/ipkg/ipkg_0.99.154.bb [deleted file]
packages/ipkg/ipkg_0.99.155.bb [deleted file]
packages/ipkg/ipkg_0.99.159.bb [deleted file]
packages/ipkg/ipkg_0.99.163.bb

index 779933b..45ede41 100644 (file)
@@ -1,6 +1,6 @@
 diff -Nur ipkg-0.99.163.orig/ipkg_install.c ipkg-0.99.163/ipkg_install.c
 --- ipkg-0.99.163.orig/ipkg_install.c  2006-03-30 21:50:24.000000000 +0800
-+++ ipkg-0.99.163/ipkg_install.c       2006-08-10 09:30:40.000000000 +0800
++++ ipkg-0.99.163/ipkg_install.c       2007-03-15 08:01:20.000000000 +0800
 @@ -211,6 +211,7 @@
        anyone ever wants to make a nice libipkg. */
  
@@ -9,9 +9,35 @@ diff -Nur ipkg-0.99.163.orig/ipkg_install.c ipkg-0.99.163/ipkg_install.c
       return ipkg_install_pkg(conf, new,0);
  }
  
+diff -Nur ipkg-0.99.163.orig/libbb/unzip.c ipkg-0.99.163/libbb/unzip.c
+--- ipkg-0.99.163.orig/libbb/unzip.c   2006-02-06 16:13:02.000000000 +0800
++++ ipkg-0.99.163/libbb/unzip.c        2007-03-15 08:03:45.000000000 +0800
+@@ -1028,13 +1028,15 @@
+  */
+ extern void gz_close(int gunzip_pid)
+ {
+-      if (kill(gunzip_pid, SIGTERM) == -1) {
+-              error_msg_and_die("***  Couldnt kill old gunzip process *** aborting");
+-      }
++      if (kill(gunzip_pid, 0) == 0) {
++              if (kill(gunzip_pid, SIGTERM) == -1) {
++                      error_msg_and_die("***  Couldnt kill old gunzip process *** aborting");
++              }
+-      if (waitpid(gunzip_pid, NULL, 0) == -1) {
+-              printf("Couldnt wait ?");
++              if (waitpid(gunzip_pid, NULL, 0) == -1) {
++                      printf("Couldnt wait ?");
++              }
+       }
+-              free(window);
+-              free(crc_table);
++      free(window);
++      free(crc_table);
+ }
 diff -Nur ipkg-0.99.163.orig/pkg.c ipkg-0.99.163/pkg.c
 --- ipkg-0.99.163.orig/pkg.c   2006-04-21 04:29:28.000000000 +0800
-+++ ipkg-0.99.163/pkg.c        2006-08-10 09:35:06.000000000 +0800
++++ ipkg-0.99.163/pkg.c        2007-03-20 15:11:32.845064480 +0800
 @@ -33,6 +33,7 @@
  #include "xsystem.h"
  #include "ipkg_conf.h"
@@ -98,7 +124,32 @@ diff -Nur ipkg-0.99.163.orig/pkg.c ipkg-0.99.163/pkg.c
               }
          } else if (strcasecmp(field, "MD5sum") == 0) {
               /* MD5sum */
-@@ -1016,6 +1049,12 @@
+@@ -871,6 +904,24 @@
+                    }
+                    temp[0]='\0';
+                    snprintf(temp, (strlen(pkg->size)+8), "Size: %s\n", pkg->size);
++             } else {
++                  if ( pkg->local_filename ) {
++                     struct stat buf;
++                   memset(&buf, 0, sizeof(struct stat));
++                   
++                   if ( stat(pkg->local_filename, &buf) == 0 ) {
++
++                      sprintf_alloc(&pkg->size, "%d", buf.st_size);
++                        temp = (char *)realloc(temp, strlen(pkg->size)+8);
++                        if ( temp == NULL ){
++                           fprintf(stderr, "%s: out of memory\n", __FUNCTION__);
++                           return NULL;
++                        }
++                        temp[0]='\0';
++                        snprintf(temp, (strlen(pkg->size)+8), "Size: %s\n", pkg->size);
++                   }
++                  }
++                     
+              }
+         } else if (strcasecmp(field, "Source") == 0) {
+              /* Source */
+@@ -1016,6 +1067,12 @@
       pkg_print_field(pkg, file, "Essential"); /* @@@@ should be removed in future release. */
       pkg_print_field(pkg, file, "Architecture");
       pkg_print_field(pkg, file, "Conffiles");
@@ -113,7 +164,7 @@ diff -Nur ipkg-0.99.163.orig/pkg.c ipkg-0.99.163/pkg.c
  }
 diff -Nur ipkg-0.99.163.orig/pkg.h ipkg-0.99.163/pkg.h
 --- ipkg-0.99.163.orig/pkg.h   2006-05-30 16:31:08.000000000 +0800
-+++ ipkg-0.99.163/pkg.h        2006-08-10 09:19:14.000000000 +0800
++++ ipkg-0.99.163/pkg.h        2007-03-15 08:01:20.000000000 +0800
 @@ -176,6 +176,10 @@
       int arch_priority;
  /* Adding this flag, to "force" ipkg to choose a "provided_by_hand" package, if there are multiple choice */
@@ -125,3 +176,4 @@ diff -Nur ipkg-0.99.163.orig/pkg.h ipkg-0.99.163/pkg.h
  };
  
  pkg_t *pkg_new(void);
+\r
diff --git a/packages/ipkg/ipkg-0.99.153/.mtn2git_empty b/packages/ipkg/ipkg-0.99.153/.mtn2git_empty
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/packages/ipkg/ipkg-0.99.153/fix-bug1393.patch b/packages/ipkg/ipkg-0.99.153/fix-bug1393.patch
deleted file mode 100644 (file)
index 86af6b1..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-patch added into upstream bugzilla:
-http://handhelds.org/~bugzilla/show_bug.cgi?id=1393
-Index: pkg_hash.c
-===================================================================
-RCS file: /cvs/familiar/dist/ipkg/C/pkg_hash.c,v
-retrieving revision 1.71
-diff -u -r1.71 pkg_hash.c
---- C/pkg_hash.c       29 Jul 2005 20:19:39 -0000      1.71
-+++ C/pkg_hash.c       2 Sep 2005 13:23:08 -0000
-@@ -216,7 +216,8 @@
-                   pkg_t *maybe = vec->pkgs[i];
-                   ipkg_message(conf, IPKG_DEBUG, "  %s arch=%s arch_priority=%d  \n",
-                                maybe->name, maybe->architecture, maybe->arch_priority);
--                  if (maybe->arch_priority > 0)  {
-+                  if ((maybe->arch_priority > 0) 
-+                      && ((constraint_fcn == NULL) || constraint_fcn(maybe, cdata))) {
-                        max_count++;
-                        abstract_pkg_vec_insert(matching_apkgs, maybe->parent);
-                        pkg_vec_insert(matching_pkgs, maybe);
diff --git a/packages/ipkg/ipkg-0.99.155/.mtn2git_empty b/packages/ipkg/ipkg-0.99.155/.mtn2git_empty
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/packages/ipkg/ipkg-0.99.155/upgrade-message-garbage.patch b/packages/ipkg/ipkg-0.99.155/upgrade-message-garbage.patch
deleted file mode 100644 (file)
index 6e79f79..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-Prevent the output of spurious extra characters from
-the stack.  This patch is in the manner of the rest of
-the code, there is no good reason for this.
-
---- C/ipkg_install.c   1970-01-01 00:00:00.000000000 +0000
-+++ C/ipkg_install.c   1970-01-01 00:00:00.000000000 +0000
-@@ -723,6 +723,7 @@ static int ipkg_install_check_downgrade(
-         return rc;
-      } else {
-       char message_out[15] ;
-+      memset(message_out,'\x0',15);
-       if ( message ) 
-           strncpy( message_out,"Upgrading ",strlen("Upgrading ") );
-       else
diff --git a/packages/ipkg/ipkg-native_0.99.152.bb b/packages/ipkg/ipkg-native_0.99.152.bb
deleted file mode 100644 (file)
index f2deb33..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-require ipkg_${PV}.bb
-require ipkg-native.inc
-PR = "r1"
diff --git a/packages/ipkg/ipkg-native_0.99.153.bb b/packages/ipkg/ipkg-native_0.99.153.bb
deleted file mode 100644 (file)
index f2deb33..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-require ipkg_${PV}.bb
-require ipkg-native.inc
-PR = "r1"
diff --git a/packages/ipkg/ipkg-native_0.99.154.bb b/packages/ipkg/ipkg-native_0.99.154.bb
deleted file mode 100644 (file)
index f2deb33..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-require ipkg_${PV}.bb
-require ipkg-native.inc
-PR = "r1"
diff --git a/packages/ipkg/ipkg-native_0.99.159.bb b/packages/ipkg/ipkg-native_0.99.159.bb
deleted file mode 100644 (file)
index f2deb33..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-require ipkg_${PV}.bb
-require ipkg-native.inc
-PR = "r1"
diff --git a/packages/ipkg/ipkg_0.99.152.bb b/packages/ipkg/ipkg_0.99.152.bb
deleted file mode 100644 (file)
index 0d10a29..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-require ipkg.inc
-PR = "r3"
diff --git a/packages/ipkg/ipkg_0.99.153.bb b/packages/ipkg/ipkg_0.99.153.bb
deleted file mode 100644 (file)
index 5852b6a..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-DEFAULT_PREFERENCE = "-1"
-
-require ipkg.inc
-
-PR = "r4"
-
-SRC_URI += "file://fix-bug1393.patch;patch=1"
-
diff --git a/packages/ipkg/ipkg_0.99.154.bb b/packages/ipkg/ipkg_0.99.154.bb
deleted file mode 100644 (file)
index 20a1996..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-require ipkg.inc
-PR = "r4"
diff --git a/packages/ipkg/ipkg_0.99.155.bb b/packages/ipkg/ipkg_0.99.155.bb
deleted file mode 100644 (file)
index e5ff6dc..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-require ipkg.inc
-PR = "r2"
-SRC_URI += "file://upgrade-message-garbage.patch;patch=1"
diff --git a/packages/ipkg/ipkg_0.99.159.bb b/packages/ipkg/ipkg_0.99.159.bb
deleted file mode 100644 (file)
index 8455050..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-require ipkg.inc
-PR = "r1"
index de3562d..627a1fb 100644 (file)
@@ -1,5 +1,5 @@
 include ipkg.inc
-PR = "r2"
+PR = "r3"
 
 S = "${WORKDIR}/ipkg-${PV}"