abiword: add 2.8.3
[openembedded.git] / recipes / xserver-common / xserver-common_1.30.bb
1 DESCRIPTION = "Common X11 scripts and support files"
2 LICENSE = "GPL"
3 SECTION = "x11"
4 RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo"
5 RRECOMMENDS_${PN} = "xtscal"
6 PR = "r5"
7
8 PACKAGE_ARCH = "all"
9 DEFAULT_PREFERENCE = "-1"
10
11 # we are using a gpe-style Makefile
12 inherit gpe
13
14 SRC_URI_append = " file://setDPI.sh \
15                    file://89xdgautostart.sh \
16 file://0018-zaurus-fixed-machine-names.patch;patch=1 \
17 file://0019-keymap-fixed-machine-names.patch;patch=1 \
18 file://0020-keymap-fixed-machine-names-again.patch;patch=1 \
19 file://0021-xserver-introduced-MOUSE-variable-for-mouse-argument.patch;patch=1 \
20 file://0022-xserver-fix-syntax-error.patch;patch=1 \
21 file://0023-Xserver-provide-screen-argument-only-for-non-X.org-s.patch;patch=1 \
22 file://0024-Xserver-move-nearly-whole-functionality-to-xserver-c.patch;patch=1 \
23 file://0025-Makefile-move-modmaps-install-xserver-common.patch;patch=1 \
24 file://0026-98keymap-fixup-fixed-path-to-xmodmap-file.patch;patch=1 \
25 "
26
27 do_install_append() {
28         install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
29         install -m 0755 "${WORKDIR}/89xdgautostart.sh" "${D}/etc/X11/Xsession.d/89xdgautostart"
30         sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/Xserver
31 }