f7ee61317054d910da0bef8774ab3158a7a381a5
[openembedded.git] / recipes / xfce-base / xfce4-session_4.6.2.bb
1 DESCRIPTION = "xfce4-session is a session manager for Xfce 4 Desktop Environment"
2 DEPENDS = "libwnck libxfcegui4 libxfce4util dbus iceauth xfce-utils"
3 SECTION = "x11"
4
5 PR = "r3"
6
7 inherit xfce46
8
9 RDEPENDS_${PN} = "iceauth xfce-utils xinit dbus-x11 libxres"
10
11 SRC_URI += "file://0001-no_tips_on_startup.patch;patch=1" 
12
13 FILES_${PN} += "${libdir}/xfce4/splash/engines/*.so"
14 FILES_${PN} += "${datadir}/xfce4/tips/*"
15 FILES_${PN} += "${datadir}/themes/Default/balou/*"
16
17 FILES_${PN}-dbg += "${libdir}/xfce4/splash/engines/.debug/*.so"
18 FILES_${PN}-dbg += "${libdir}/xfce4/splash/engines/.debug/*.a"
19
20 FILES_${PN}-dev += "${libdir}/xfce4/splash/engines/*.la"
21 FILES_${PN}-dev += "${libdir}/xfce4/splash/engines/*.a"
22
23 pkg_postinst_${PN} () {
24 #!/bin/sh
25 # old cache seems to be incompatible and causes
26 # xfce4-session to crash, must delete..
27   rm -rf $HOME/Applications/Cache
28   user=`cat /tmp/currentuser 2> /dev/null`
29   test -n "$user" && rm -rf /home/$user/Applications/Cache
30 }
31
32 SRC_URI[md5sum] = "9d9890130e45e0e9476591ed9ba2c9d5"
33 SRC_URI[sha256sum] = "725e269254c34c530acb670f5ccd0fd69b57cbe9f2176abd8499fc5d6dcd30a8"