sg3-utils: add newer buildable version
[openembedded.git] / recipes / woodstox / woodstox2_2.0.6.bb
1 DESCRIPTION = "High-performance XML processor."
2 LICENSE = "AL2.0 LGPL2.1"
3
4 AUTHOR = "Codehaus"
5 HOMEPAGE = "http://woodstox.codehaus.org"
6
7 SRC_URI = "http://woodstox.codehaus.org/2.0.6/wstx-src.tar.gz"
8
9 S = "${WORKDIR}"
10
11 inherit java-library
12
13 DEPENDS = "fastjar-native"
14
15 do_compile() {
16   mkdir -p build/META-INF/services
17
18   javac -nowarn -sourcepath src/java -d build \
19                 `find src/java/org -name "*.java"` \
20                 `find src/java/com -name "*.java"`
21
22   cp -r src/resources/* build/META-INF/services
23
24   fastjar -C build -c -f ${JARFILENAME} .
25 }