netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / vlan / vlan_1.9.bb
1 DESCRIPTION = "802.1q vlan support program"
2 RRECOMMENDS = "kernel-module-8021q"
3 PR = "r0"
4
5 S = "${WORKDIR}/vlan/"
6
7 SRC_URI = " \
8         http://www.candelatech.com/~greear/vlan/vlan.${PV}.tar.gz \
9         file://ip \
10         file://vlan-pre-up \
11         file://vlan-post-down \
12         "
13
14 inherit base
15
16 CCFLAGS = "-g -D_GNU_SOURCE -Wall -I${STAGING_INCDIR}"
17 LDLIBS = ""
18
19 do_compile() {
20         ${CC} ${CCFLAGS} -c vconfig.c
21         ${CC} ${CCFLAGS} ${LDFLAGS} -o vconfig vconfig.o ${LDLIBS}
22 }
23
24 do_install() {
25         install -d "${D}${sbindir}"
26         install -m 755 "${S}/vconfig" "${D}${sbindir}/vconfig"
27         install -d ${D}/${sysconfdir}/network/if-pre-up.d
28         install -d ${D}/${sysconfdir}/network/if-post-down.d
29         install -d ${D}/${sysconfdir}/network/if-up.d
30         install -m 0755 ${WORKDIR}/ip ${D}/${sysconfdir}/network/if-up.d/
31         install -m 0755 ${WORKDIR}/vlan-pre-up ${D}/${sysconfdir}/network/if-pre-up.d/vlan
32         install -m 0755 ${WORKDIR}/vlan-post-down ${D}/${sysconfdir}/network/if-post-down.d/vlan
33 }
34