netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / usrp / usrp_0.12.bb
1 DESCRIPTION = "Support software for the Universal Software Radio Peripheral (USRP)"
2 LICENSE = "GPL"
3 HOMEPAGE = "http://comsec.com/wiki?UniversalSoftwareRadioPeripheral"
4 SECTION = "devel"
5 DEPENDS = "swig-native sdcc-native virtual/libusb0 python boost"
6 RDEPENDS = "python-core"
7 PR = "r1"
8
9 SRC_URI = "ftp://ftp.gnu.org/gnu/gnuradio/usrp-${PV}.tar.gz \
10            file://fix_compile_h.patch;patch=1;pnum=3 \
11            file://install_test.patch;patch=1"
12
13 SRC_URI_append_omap5912osk = "file://usb11.patch;patch=1"
14
15 S = "${WORKDIR}/usrp-${PV}"
16
17 inherit autotools pkgconfig python-dir
18
19 CXXFLAGS_powerpc += "-lstdc++"
20
21 export BUILD_SYS := "${BUILD_SYS}"
22 export HOST_SYS := "${HOST_SYS}"
23
24 do_stage () {
25      oe_libinstall -so -C host/lib/.libs/ libusrp ${STAGING_LIBDIR}
26
27      install -m 644 host/lib/usrp_basic.h ${STAGING_INCDIR}
28      install -m 644 host/lib/usrp_bytesex.h ${STAGING_INCDIR}
29      install -m 644 host/lib/usrp_config.h ${STAGING_INCDIR}
30      install -m 644 host/lib/usrp_dbid.h ${STAGING_INCDIR}
31      install -m 644 host/lib/usrp_prims.h ${STAGING_INCDIR}
32      install -m 644 host/lib/usrp_slots.h ${STAGING_INCDIR}
33      install -m 644 host/lib/usrp_standard.h ${STAGING_INCDIR}
34
35      install -m 644 firmware/include/usrp_i2c_addr.h ${STAGING_INCDIR}
36      install -m 644 firmware/include/usrp_spi_defs.h ${STAGING_INCDIR}
37 }
38
39 PACKAGES += "python-pyusrp-dbg python-pyusrp"
40 FILES_python-pyusrp-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug"
41 FILES_python-pyusrp = "${libdir}/python*"