netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / uclibc / bfin-uclibc_svn.bb
1 # UCLIBC_BASE should be the latest released revision of uclibc (that way
2 # the config files will typically be correct!)  uclibc-cvs takes precedence
3 # over uclibc-${UCLIBC_BASE}, if a config file in uclibc-cvs is out of date
4 # try removing it
5 #
6 # UCLIBC_BASE can be set in a distro file, but whether this works depends
7 # on whether the base patches apply to the selected (SRCDATE) svn release.
8 #
9 UCLIBC_BASE ?= "0.9.29"
10 PV = "${UCLIBC_BASE}+svnr${SRCPV}"
11
12 require uclibc.inc
13 PR = "${INC_PR}.0"
14 SRCREV = "1857"
15 PROVIDES_append_bfin = " virtual/${TARGET_PREFIX}libc-for-gcc "
16
17 #recent versions uclibc require real kernel headers
18 PACKAGE_ARCH = "${MACHINE_ARCH}"
19 COMPATIBLE_HOST = "bfin.*-uclinux"
20
21 #as stated above, uclibc needs real kernel-headers
22 #however: we can't depend on virtual/kernel when nptl hits due to depends deadlocking ....
23 KERNEL_SOURCE = "${CROSS_DIR}/${TARGET_SYS}"
24
25 SRC_URI = "svn://sources.blackfin.uclinux.org/toolchain/trunk;module=uClibc "
26 SRC_URI += "file://uClibc.machine file://uClibc.distro"
27
28 FILESPATHPKG =. "uclibc-${UCLIBC_BASE}:uclibc:"
29
30
31 S = "${WORKDIR}/uClibc"
32