sg3-utils: add newer buildable version
[openembedded.git] / recipes / uae / e-uae_0.8.28.bb
1 DESCRIPTION = "Amiga Emulator based on SDL"
2 SECTION = "base"
3 PRIORITY = "optional"
4 DEPENDS = "virtual/libsdl zlib"
5 LICENSE = "GPL"
6 PR = "r1"
7
8 SRC_URI = "http://rcdrummond.net/uae/e-uae-${PV}/e-uae-${PV}.tar.bz2 \
9            file://configure.patch;patch=1"
10
11 inherit autotools
12
13 export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
14
15 EXTRA_OECONF = "--with-hostcc=gcc --disable-ui --without-x \
16                 --without-gtk --enable-jit --disable-natmem \
17                 --with-zlib=${STAGING_LIBDIR}/.."
18
19 CFLAGS_append = " -DSTAT_STATFS2_BSIZE=1 "
20 CXXFLAGS_append = " -DSTAT_STATFS2_BSIZE=1 "
21 PARALLEL_MAKE = ""
22
23 export S
24 export PKG_CONFIG="${STAGING_BINDIR_NATIVE}/pkg-config"
25
26 do_configure_prepend () {
27         sed -i -e s:getline:etline:g ./src/gui-none/nogui.c
28         touch NEWS AUTHORS ChangeLog
29 }