Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[openembedded.git] / recipes / squashfs-tools / squashfs-tools_4.0.bb
1 require squashfs-tools.inc
2 PR = "${INC_PR}.2"
3
4 # This override is required since this has not yet been released
5 SRC_URI  = "cvs://anonymous@squashfs.cvs.sourceforge.net/cvsroot/squashfs;module=squashfs;date=${SRCDATE} \
6             http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2"
7 S = "${WORKDIR}/squashfs/squashfs-tools"
8
9 EXTRA_OEMAKE += "LZMA_SUPPORT=1 LZMA_DIR=../.."
10 TARGET_CC_ARCH += "${LDFLAGS}"
11
12 # the COMP_DEFAULT macro should result in a string including quotes: "gzip"
13 COMP_DEFAULT = gzip
14 CFLAGS_append = ' -I. -I../../C -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
15  -D_GNU_SOURCE -DLZMA_SUPPORT -DCOMP_DEFAULT=\\"${COMP_DEFAULT}\\" '