frameworkd-config-shr: fix a nasty typo
[openembedded.git] / recipes / shr / frameworkd-config-shr_git.bb
1 DESCRIPTION = "SHR Configuration for frameworkd"
2 HOMEPAGE = "http://www.freesmartphone.org"
3 AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de> et. al."
4 SECTION = "console/network"
5 DEPENDS = "python-cython-native python-pyrex-native"
6 LICENSE = "GPL"
7 SRCREV_FORMAT = "FSO_REV-SHR_REV"
8 PV = "0.9.5.9+gitr${SRCREV}"
9 PR = "r7"
10
11 SRC_URI = "${FREESMARTPHONE_GIT}/framework.git;protocol=git;branch=master;name=FSO_REV \
12            git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master;name=SHR_REV"
13 S = "${WORKDIR}/git"
14
15 PROVIDES_${PN} = "frameworkd-config"
16 RPROVIDES_${PN} = "frameworkd-config"
17 CONF_PATH = "${S}/frameworkd/${PN}"
18
19 do_install_append() {
20         install -d ${D}${sysconfdir}
21         install -d ${D}${sysconfdir}/freesmartphone/opreferences/schema/
22         install -d ${D}${sysconfdir}/freesmartphone/opreferences/conf/profiles/
23         install -d ${D}${sysconfdir}/freesmartphone/opreferences/conf/phone/
24         install -d ${D}${sysconfdir}/freesmartphone/opreferences/conf/rules/
25         install -d ${D}${sysconfdir}/freesmartphone/oevents/
26         install -d ${D}${sysconfdir}/freesmartphone/ogsmd/
27         install -d ${D}${sysconfdir}/freesmartphone/persist/
28         install -d ${D}${sysconfdir}/freesmartphone/opim/
29         install -m 0644 ${S}/etc/freesmartphone/opreferences/schema/phone.yaml ${D}${sysconfdir}/freesmartphone/opreferences/schema/
30         install -m 0644 ${S}/etc/freesmartphone/opreferences/schema/profiles.yaml ${D}${sysconfdir}/freesmartphone/opreferences/schema/
31         install -m 0644 ${S}/etc/freesmartphone/opreferences/schema/rules.yaml ${D}${sysconfdir}/freesmartphone/opreferences/schema/
32         install -m 0644 ${S}/etc/freesmartphone/persist/README ${D}${sysconfdir}/freesmartphone/persist/
33         install -m 0644 ${S}/etc/freesmartphone/ogsmd/networks.tab ${D}${sysconfdir}/freesmartphone/ogsmd/
34         install -m 0644 ${S}/etc/freesmartphone/ogsmd/cell.db ${D}${sysconfdir}/freesmartphone/ogsmd/
35         install -m 0644 ${S}/etc/freesmartphone/ogsmd/la.db ${D}${sysconfdir}/freesmartphone/ogsmd/
36
37         #Check for machine specific conf.
38         CONF_PATH_MACHINE="${CONF_PATH}"
39         if [ -d "${CONF_PATH}/${MACHINE}" ] ; then
40                 CONF_PATH_MACHINE="${CONF_PATH}/${MACHINE}"
41         fi
42         # Install SHR custom files
43         install -m 0644 ${CONF_PATH_MACHINE}/frameworkd.conf ${D}${sysconfdir}
44         install -m 0644 ${CONF_PATH_MACHINE}/rules.yaml ${D}${sysconfdir}/freesmartphone/oevents/
45         install -m 0644 ${CONF_PATH}/profiles/profiles/default.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/profiles/
46
47         install -m 0644 ${CONF_PATH}/profiles/phone/default.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/phone/
48         install -m 0644 ${CONF_PATH}/profiles/rules/default.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/rules/
49
50         install -m 0644 ${CONF_PATH}/profiles/phone/ring.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/phone/
51         install -m 0644 ${CONF_PATH}/profiles/rules/ring.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/rules/
52
53         install -m 0644 ${CONF_PATH}/profiles/phone/vibrate.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/phone/
54         install -m 0644 ${CONF_PATH}/profiles/rules/vibrate.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/rules/
55
56         install -m 0644 ${CONF_PATH}/profiles/phone/silent.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/phone/
57         install -m 0644 ${CONF_PATH}/profiles/rules/silent.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/rules/
58
59         install -d ${D}${datadir}/sounds
60         install -m 0644 ${CONF_PATH}/*.wav ${D}${datadir}/sounds/
61 }
62
63 PACKAGE_ARCH_${PN} = "${MACHINE_ARCH}"
64
65 # machine specific stuff, should ideally be elsewhere
66 # - recommend MUXer on platforms that require one
67 RDEPENDS_${PN}_append_om-gta01 = " fso-abyss"
68 RDEPENDS_${PN}_append_om-gta02 = " fso-abyss"
69 RDEPENDS_${PN}_append_om-3d7k  = " fso-abyss"
70 # - add wmiconfig for wireless configuration
71 RDEPENDS_${PN}_append_om-gta02 = " wmiconfig"
72
73 FILES_${PN} = "\
74   ${sysconfdir}/frameworkd.conf \
75   ${sysconfdir}/freesmartphone \
76   ${datadir}/sounds \
77 "
78 CONFFILES_${PN} = "\
79   ${sysconfdir}/frameworkd.conf \
80   ${sysconfdir}/freesmartphone/opreferences/conf/phone/silent.yaml \
81   ${sysconfdir}/freesmartphone/opreferences/conf/phone/default.yaml \
82   ${sysconfdir}/freesmartphone/opreferences/conf/profiles/default.yaml \
83   ${sysconfdir}/freesmartphone/opreferences/conf/rules/silent.yaml \
84   ${sysconfdir}/freesmartphone/opreferences/conf/rules/default.yaml \
85   ${sysconfdir}/freesmartphone/oevents/rules.yaml \
86   ${sysconfdir}/freesmartphone/ogsmd/networks.tab \
87 "