netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / sharprom-toolchain / sharprom-toolchain-native_1.0.bb
1 DESCRIPTION = "Precompiled SharpROM toolchain glue package"
2 LICENSE = "GPL"
3 SECTION = "base"
4 # see bug 2199 for the reason the following line is in here
5 DEPENDS = "linux-libc-headers cross-linkage staging-linkage"
6 PROVIDES_sharprom-compatible = "\
7   virtual/arm-linux-gcc-2.95 \
8   virtual/arm-linux-libc-for-gcc \
9   virtual/arm-linux-libc-initial \
10   virtual/arm-linux-binutils \
11   virtual/libc \
12   virtual/libintl \
13   virtual/libiconv \
14   virtual/arm-linux-gcc \
15   virtual/arm-linux-libc-for-gcc \
16   virtual/arm-linux-gcc-intermediate \
17   virtual/arm-linux-gcc-initial "
18 PR = "r3"
19
20 RPROVIDES = "glibc-utils libsegfault glibc-thread-db libgcc-dev libstdc++-dev libstdc++"
21 PACKAGES_DYNAMIC = "glibc-gconv-*"
22
23 # This needs to be extracted to /usr/local/arm :
24 # SRC_URI = "http://handhelds.org/download/projects/toolchain/archive/cross-2.95.3.tar.bz2"
25
26 inherit native
27
28 COMPATIBLE_HOST = 'i.86.*-linux'
29
30 do_stage() {
31         if [ ! -e /usr/local/arm/2.95.3/bin/arm-linux-gcc-2.95 ]
32         then
33                 die "You need to install the Sharp Toolchain to /usr/local/arm and rename the compiler to arm-linux-gcc-2.95"
34         fi
35         if [ ! -e /usr/local/arm/2.95.3/bin/arm-linux-ld-2.11.2 ]
36         then
37                 die "You need to install the Sharp Toolchain to /usr/local/arm and rename the linker to arm-linux-ld-2.11.2"
38         fi
39         ln -sf /usr/local/arm/2.95.3/bin/arm-linux-gcc-2.95 ${STAGING_BINDIR}/arm-linux-gcc
40         ln -sf /usr/local/arm/2.95.3/bin/arm-linux-ld-2.11.2 ${STAGING_BINDIR}/arm-linux-ld
41 }
42