netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / scim / scim_1.4.9.bb
1 DESCRIPTION = "Smart Common Input Method (SCIM) platform"
2 HOMEPAGE = "http://www.scim-im.org"
3 SECTION = "libs/inputmethod"
4 LICENSE = "LGPL"
5 DEPENDS = "gtk+"
6 PR = "r1"
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.gz \
9            file://gcc-4.4-const-char.dpatch;patch=1 \
10            file://configure.patch;patch=1 \
11            file://20_scim_config.dpatch;patch=1 \
12            file://40_scim_user_home_overrides.dpatch;patch=1 \
13            file://50_validate-desktop-entry.dpatch;patch=1 \
14            file://51_scim-1.4.7-fix-capslock.dpatch;patch=1 \
15            file://52_scim-1.4.7-imdkit-read-property-properly.dpatch;patch=1 \
16            file://53_scim-1.4.7-trayicon.dpatch;patch=1 \
17            file://54_scim-1.4.7-xim-wrong-format.dpatch;patch=1 \
18            file://scim-1.4.7-syslibltdl.patch;patch=1 \
19            "
20
21 inherit autotools pkgconfig
22
23 EXTRA_OECONF = " --without-doxygen "
24 LEAD_SONAME = "libscim-1.0.so"
25
26 PDIR = "${PN}-1.0"
27
28 do_configure_append () {
29         # Fix unset @ALL_LINGUAS@
30         #   Replace with a list of available translations in ${S}/po
31
32         cd ${S}/po
33         SEDR=`ls *.gmo -1 --color=none | sed 's/.gmo//' | tr '\n' ' '`
34         SEDL='@ALL_LINGUAS@'
35         sed -i "s/${SEDL}.*/${SEDR}/" Makefile.in.in
36         sed -i "s/${SEDL}.*/${SEDR}/" Makefile.in
37         sed -i "s/${SEDL}.*/${SEDR}/" Makefile
38
39         # Fix unset @INTLTOOL_LIBDIR@
40         #   Only needed for a check to see if charmap.alias is present,
41         #   not really needed, so we fail that test by having it look
42         #   in ${S}
43
44         cd ${S}
45         sed -i 's/@INTLTOOL_LIBDIR@/./' intltool-merge.in
46         sed -i 's/@INTLTOOL_LIBDIR@/./' intltool-merge
47
48         # Fix unset @GTK_LIBDIR@
49         #   This is the same as ${libdir} so we use that
50
51         cd ${S}/extras/gtk2_immodule
52         sed -i 's/@GTK_LIBDIR@/$(libdir)/g' Makefile.in
53         sed -i 's/@GTK_LIBDIR@/$(libdir)/g' Makefile.am
54 }
55
56 pkg_postinst_${PN} () {
57         # Update gtk2 immodules
58         #   Adds SCIM to the list
59         /usr/bin/gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
60 }
61
62 pkg_postrm_${PN} () {
63         # Update gtk2 immodules
64         #   Removes SCIM from the list
65         /usr/bin/gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
66 }
67
68 FILES_${PN}-dbg +=   "${libdir}/${PDIR}/.debug \
69                       ${libdir}/${PDIR}/1.4.0/*/.debug \
70                       ${libdir}/gtk-2.0/immodules/.debug"
71 FILES_${PN} +=       "${libdir}/${PDIR}/scim-panel-gtk \
72                       ${libdir}/${PDIR}/scim-helper* \
73                       ${libdir}/${PDIR}/scim-launcher \
74                       ${libdir}/${PDIR}/1.4.0 \
75                       ${libdir}/gtk-2.0/immodules"