netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / rocksndiamonds / rocksndiamonds_3.2.0.bb
1 DESCRIPTION = "Rocks'n'Diamonds - Boulderdash/Emerald Mine/Supaplex/Sokoban clone."
2 SECTION = "games"
3 LICENSE = "GPL"
4 HOMEPAGE = "http://www.artsoft.org/rocksndiamonds/"
5 AUTHOR = "Holger Schemel <info@artsoft.org>"
6
7 DEFAULT_PREFERENCE = "-1"
8
9 SRC_URI = "http://artsoft.org/RELEASES/unix/rocksndiamonds/rocksndiamonds-${PV}.tar.gz \
10         file://rocksndiamonds.png"
11
12 DEPENDS += "libsdl-net smpeg"
13
14 APPIMAGE = "../rocksndiamonds.png"
15 EXTRA_OEMAKE = "CC='${CC}' AR='${AR}' RANLIB='${RANLIB}' RO_GAME_DIR='${datadir}/${PN}' RW_GAME_DIR='${datadir}/${PN}'"
16
17 inherit sdl
18
19 do_install() {
20         install -d ${D}${bindir}
21         install -m 755 ${PN} ${D}${bindir}
22         install -d ${D}${datadir}/${PN}
23         cp -r graphics levels music scores sounds ${D}${datadir}/${PN}/
24 }
25
26
27 FILES_${PN} += "${bindir}/${PN} ${datadir}/${PN}"