sg3-utils: add newer buildable version
[openembedded.git] / recipes / readline / readline_5.2.bb
1 DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \
2 command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes  \
3 additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those   \
4 lines, and perform csh-like history expansion on previous commands."
5 SECTION = "libs"
6 PRIORITY = "optional"
7 LICENSE = "GPLv2"
8 DEPENDS += "ncurses"
9 RPROVIDES_${PN} += "readline"
10 LEAD_SONAME = "libreadline.so"
11 PR = "r6"
12
13 SRC_URI = "\
14   ftp://ftp.gnu.org/gnu/readline/readline-${PV}.tar.gz \
15   file://fix-includes.patch;patch=1 \
16   file://configure_fix.patch;patch=1 \
17   file://acinclude.m4 \
18 "
19 S = "${WORKDIR}/readline-${PV}"
20
21 inherit autotools
22
23 do_configure () {
24         install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
25         autotools_do_configure
26 }
27
28 do_install () {
29         autotools_do_install
30         # Make install doesn't properly install these
31         oe_libinstall -so -C shlib libhistory ${D}${libdir}
32         oe_libinstall -so -C shlib libreadline ${D}${libdir}
33 }
34 NATIVE_INSTALL_WORKS = 1
35 BBCLASSEXTEND = "native"
36