abiword: add 2.8.3
[openembedded.git] / recipes / qpe-games / win4_1.0.1.bb
1 DESCRIPTION = "4 wins"
2 SECTION = "opie/games"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 AUTHOR = "Anders Widell, Steve Dunham, Robert Ernst"
6 HOMEPAGE = "http://www.linux-solutions.at/projects/zaurus/games-Win4.html"
7
8
9 SRC_URI = "http://handhelds.org/~zecke/oe_packages/win4_V1.0.1.tar.gz \
10            file://win4.patch;patch=1"
11
12 PV = "1.0.1"
13 S = "${WORKDIR}/win4_V${PV}"
14
15 APPNAME = "win4"
16 APPTYPE = "binary"
17 APPDESKTOP = "${S}"
18
19
20 do_compile_prepend() {
21         oe_runmake -C images
22 }
23
24 do_install () {
25         install -d ${D}${palmtopdir}/apps/Games/
26         install -d ${D}${palmtopdir}/pics/${APPNAME}/
27         install -m 0644 ${S}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
28         install -m 0644 ${S}/${APPNAME}.desktop ${D}${palmtopdir}/apps/Games
29 }
30
31
32 inherit opie