sg3-utils: add newer buildable version
[openembedded.git] / recipes / qpe-games / atomic_1.0.1.bb
1 DESCRIPTION = "Atomic"
2 SECTION = "opie/games"
3 PRIORITY = "optional"
4
5 LICENSE = "GPL"
6 AUTHOR = "Andre Wuest"
7 HOMEPAGE = "http://www.linux-solutions.at/projects/zaurus/games-Atomic.html"
8
9
10 SRC_URI = "http://handhelds.org/~zecke/oe_packages/atomic_V1.0.1.tar.gz \
11            file://atomic.patch;patch=1"
12
13
14 PV = "1.0.1"
15 S = "${WORKDIR}/atomic_V${PV}"
16 APPNAME = "atomic"
17 APPTYPE = "binary"
18 APPDESKTOP = "${S}"
19
20
21
22
23 do_compile_prepend() {
24         oe_runmake -C images
25         oe_runmake -C tools
26         oe_runmake -C levels
27 }
28
29 do_install () {
30         install -d ${D}${palmtopdir}/pics/${APPNAME}/
31         install -m 0644 ${S}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
32
33 }
34
35 inherit opie