netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / pythm / pythm_svn.bb
1 DESCRIPTION = "Pythm is a media player gui designed to work with mplayer or mpd as "slave" players.\
2 use mplayer to hear music on the road or mpd control if your are at home."
3 HOMEPAGE = "http://projects.openmoko.org/projects/pythm/"
4 SECTION = "application/multimedia"
5 LICENSE = "GPLv2"
6 SRCNAME = "pythm"
7 SRCREV = "19"
8 PV = "0.5.1+svnr${SRCPV}"
9 PR = "r3"
10 SRC_URI = "svn://svn.projects.openmoko.org/svnroot/;module=pythm \
11            file://mplayer-escape-filenames.patch;patch=0 \
12            file://pythm.desktop \
13            file://pythm.conf"
14 S = "${WORKDIR}/pythm"
15
16 inherit setuptools
17
18 RDEPENDS_${PN} = "\
19   python-pygtk \
20   mplayer \
21 "
22 DISTUTILS_INSTALL_ARGS = "--root=${D} \
23     --prefix=${prefix} \
24     --install-data=${datadir}"
25
26 do_install_append() {
27         install -d ${D}${sysconfdir}
28         install -d ${D}/${datadir}/applications
29         install -m 0644 ../pythm.conf ${D}${sysconfdir}
30         install -m 0644 ../pythm.desktop ${D}/${datadir}/applications
31 }
32
33
34 FILES_${PN} += "\
35   ${sysconfdir}/pythm.conf \
36   ${datadir}/applications/pythm.desktop"
37