omap3-sgx-modules: add 4.00.00.01 release from openembedded.org
[openembedded.git] / recipes / powervr-drivers / omap3-sgx-modules_1.4.14.2616.bb
1 DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2 LICENSE = "GPLv2"
3
4 # download required binary distribution from:
5 # http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
6 # see libgles-omap3.inc for detailed installation instructions
7
8 TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
9 require ../ti/ti-eula-unpack.inc
10
11 SGXPV = "4_00_00_01"
12 IMGPV = "1.4.14.2616"
13 BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin"
14
15 inherit module
16
17 MACHINE_KERNEL_PR_append = "h"
18
19 SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/Graphics_SDK_setuplinux_${SGXPV}.bin \
20            file://0002-Compile-fixes-for-recent-kernels.patch \
21            file://update.patch \
22            file://0001-OMAP3-SGX-TI-4.00.00.01-2.6.37-rc1-use-semaphore-ove.patch \
23 "
24
25 SRC_URI[md5sum] = "a027002dcd7164df467b1a315788d5fd"
26 SRC_URI[sha256sum] = "62383d15e33adf9349afba063b0f2405a15aa6c4b0b5579b0abdf81db7580df7"
27
28 S = "${WORKDIR}/Graphics_SDK_${SGXPV}/GFX_Linux_KM"
29
30 PVRBUILD = "release"
31
32 PACKAGE_STRIP = "no"
33
34 TI_PLATFORM_omap3 = "omap3630"
35 TI_PLATFORM_ti816x = "ti8168"
36
37 MODULESLOCATION_omap3 = "dc_omap3430_linux"
38 MODULESLOCATION_ti816x = "dc_ti8168_linux"
39
40 MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM}"
41
42 do_install() {
43         mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
44         cp ${S}/pvrsrvkm.ko \
45            ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko  \
46            ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
47            ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
48 }