php_5.2.11.bb : add --enable-mbstring site/arm-common : add magic value for mbstring...
[openembedded.git] / recipes / php / php_5.2.11.bb
1 require php.inc
2
3 DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native mysql"
4
5 PR = "r1"
6
7 SRC_URI += "file://pear-makefile.patch;patch=1 \
8             "
9 export THREADS="pthread"
10 export LIBS=" -lpthread "
11
12 EXTRA_OECONF = "    --without-iconv \
13                     --enable-mbstring \
14                     --enable-discard-path \
15                     --enable-sockets \
16                     --enable-shared \
17                     --enable-pcntl \
18                     --enable-memory-limit \
19                     --enable-wddx \
20                     --enable-embedded-mysqli \
21                     --enable-magic-quotes \
22                     --enable-fastcgi \
23                     --with-zlib --with-zlib-dir=${STAGING_LIBDIR}/.. \
24                     --with-libxml-dir=${STAGING_BINDIR_CROSS} \
25                     --with-mysql="${STAGING_DIR_TARGET}${layout_exec_prefix}" \
26 #                   --with-mysqli = "${STAGING_BINDIR_NATIVE}/mysql_config" \
27                     --without-pdo-sqlite \
28                "
29
30 export LD_LIBRARY_PATH = "${STAGING_LIBDIR}"
31 export PHP_NATIVE_DIR = "${STAGING_BINDIR_NATIVE}"
32 export PHP_PEAR_PHP_BIN = "${bindir}/php"
33
34 do_configure_append() {
35     find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
36 }
37
38 # fixme
39 do_install_append() {
40     mv ${D}/${STAGING_DIR_NATIVE}/${sysconfdir} ${D}/${sysconfdir}
41     rm -rf ${D}/${STAGING_DIR_NATIVE}
42     rm -rf ${D}/.registry
43     rm -rf ${D}/.channels
44     rm -rf ${D}/.[a-z]*
45 }
46
47 PACKAGES = "${PN}-dbg \
48             ${PN}-cli \
49             ${PN}-cgi \
50             ${PN}-pear \
51             ${PN}-dev \
52             ${PN}-doc \
53             ${PN} \
54 "
55
56
57 FILES_${PN}-dbg            =+ "${bindir}/.debug"
58
59 FILES_${PN}-doc            += "${libdir}/php/doc" 
60
61 FILES_${PN}-cli            = "${bindir}/php"
62 FILES_${PN}-cgi            = "${bindir}/php-cgi"
63
64 FILES_${PN}-pear            = "${bindir}/pear* ${bindir}/pecl \
65                              ${libdir}/php/PEAR \
66                              ${libdir}/php/PEAR.php \
67                              ${libdir}/php/System.php ${libdir}php/peclcmd.php ${libdir}/php/pearcmd.php \
68                              ${libdir}/php/.channels  ${libdir}/php/.channels/.alias  \
69                              ${libdir}/php/.channels\__uri.reg \
70                              ${libdir}/php/.channels\pear.php.net.reg ${libdir}/php/.channels/pecl.php.net.reg \
71                              ${libdir}/php/.registry \
72                              ${libdir}/php/Archive/Tar.php \
73                              ${libdir}/php/Console/Getopt.php ${libdir}/php/OS/Guess.php \
74                              ${sysconfdir}/pear.conf"
75
76
77 FILES_${PN}-dev            = "${includedir}/php ${libdir}/build \
78                              ${bindir}/phpize ${bindir}/php-config \
79                              ${libdir}/php/.depdb ${libdir}/php/.depdblock ${libdir}/php/.filemap ${libdir}/php/.lock \
80                              ${libdir}/php/test "
81
82 FILES_${PN}                 = "${libdir}/php"
83 FILES_${PN}                += "${bindir}"
84
85 RDEPENDS_${PN}-pear         = ${PN}
86 RDEPENDS_${PN}-cli          = ${PN}
87 RDEPENDS_${PN}-dev          = ${PN}