netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / perl / libnetaddr-ip-perl_4.027.bb
1 DESCRIPTION = "Perl module to manage IPv4 and IPv6 addresses and subnets"
2 SECTION = "libs"
3 LICENSE = "Artistic|GPL"
4 DEPENDS = "libtest-pod-perl-native"
5 RDEPENDS_${PN} += "perl-module-test-more"
6 BBCLASSEXTEND = "native"
7
8 PR = "r0"
9
10 SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIKER/NetAddr-IP-${PV}.tar.gz;name=netaddr-ip-perl-${PV}"
11 SRC_URI[netaddr-ip-perl-4.027.md5sum] = "c4a21a76e5b1b9f4c8e9810b78559d7b"
12 SRC_URI[netaddr-ip-perl-4.027.sha256sum] = "e26b76d65e83841ba618bbe9ea913159e5e0e14a1e611b3ff870ed41e60077e0"
13
14 S = "${WORKDIR}/NetAddr-IP-${PV}"
15
16 inherit cpan
17
18 do_configure_prepend() {
19         cd Lite/Util
20         oenote Executing autoreconf --verbose --install --force
21         mkdir -p m4
22         autoreconf -Wcross --verbose --install --force || oefatal "autoreconf execution failed."
23         ./configure --build=${BUILD_SYS} --host=${HOST_SYS} \
24                 --target=${TARGET_SYS} --prefix=${prefix} --exec_prefix=${exec_prefix} \
25                 --bindir=${bindir} --sbindir=${sbindir} --libexecdir=${libexecdir} \
26                 --datadir=${datadir} --sysconfdir=${sysconfdir} \
27                 --sharedstatedir=${sharedstatedir} --localstatedir=${localstatedir} \
28                 --libdir=${libdir} --includedir=${includedir} \
29                 --oldincludedir=${oldincludedir} --infodir=${infodir} --mandir=${mandir}
30         cd ${S}
31 }