33d9987463dcbedf28a04b0650a6a6015a18a054
[openembedded.git] / recipes / opkg / opkg-nogpg_svn.bb
1 require opkg_svn.bb
2
3 DEPENDS = "curl"
4 PROVIDES += "opkg"
5
6 PR = "${INC_PR}.1"
7
8 SRCREV = "${SRCREV_pn-opkg}"
9
10 EXTRA_OECONF += " --disable-gpg \ 
11                   --disable-openssl \ 
12                   --disable-ssl-curl \
13                   --enable-gpg=no \
14                   --enable-ssl-curl=no \
15                   --enable-openssl=no"
16
17 LDFLAGS_append = " -Wl,--as-needed"
18
19 # The nogpg version isn't getting much love and has an unused variable which trips up -Werror
20 do_configure_prepend() {
21         sed -i -e s:-Werror::g ${S}/libopkg/Makefile.am
22 }
23 do_configure_prepend_nylon() {
24         LDFLAGS="`echo "$LDFLAGS" | sed "s/ -Wl,--as-needed//"`"
25 }
26
27 DEFAULT_PREFERENCE = "-1"