ncurses: add xterm terminfo file back
[openembedded.git] / recipes / openttd / openttd_0.7.4.bb
1 DESCRIPTION = "Open source clone of the Microprose game 'Transport Tycoon Deluxe' - SDL edition."
2 HOMEPAGE = "http://www.openttd.org"
3 LICENSE = "GPLv2"
4 DEPENDS = "libsdl-net libpng zlib freetype fontconfig"
5 RRECOMMENDS = "openttd-gfx openttd-sfx"
6
7 inherit siteinfo sdl
8
9 SRC_URI ="http://binaries.openttd.org/releases/${PV}/${P}-source.tar.bz2 "
10 SRC_URI_append_shr = " file://openttd.cfg"
11
12 APPIMAGE = "media/openttd.128.png"
13
14 do_configure() {
15   # The way the OTTD configure system handles the application's directories
16   # isn't the way autotools does it. Mainly prefix is always prepended even if
17   # absolute binary-dir and data-dir is given. 
18
19   ${S}/configure \
20         --host=${TARGET_SYS} \
21         --windres=${MACHINE_DISPLAY_WIDTH_PIXELS}x${MACHINE_DISPLAY_HEIGHT_PIXELS} \
22         --os=UNIX \
23         --endian=${SITEINFO_ENDIANESS} \
24         --prefix-dir=${prefix} \
25         --binary-dir=bin \
26         --with-midi=/bin/true \
27         --with-zlib=${STAGING_LIBDIR} \
28         --with-png \
29         --with-freetype \
30         --without-icu \
31         --without-allegro \
32         --cc-build=gcc \
33         --cc-host=${TARGET_SYS}-gcc \
34         --cxx-build=g++ \
35         --cxx-host=${TARGET_SYS}-g++ \
36         --strip=${TARGET_SYS}-strip \
37         --install-dir=${D}
38 }
39
40 do_install() {
41         oe_runmake install
42 }
43
44 do_install_append_shr() {
45         install -d ${D}${datadir}/games/openttd/data/
46         install -m 0644 ${WORKDIR}/openttd.cfg ${D}${datadir}/games/openttd/data/
47 }
48
49 FILES_${PN} += "${datadir}"