bluez: Add 4.62 and update include to support new style checksums for the archive.
[openembedded.git] / recipes / openscada / openscada_svn.bb
1 # Copyright (C) 2009 Khem Raj <raj.khem@gmail.com>
2 # Released under the MIT license (see COPYING.MIT for the terms)
3
4 DESCRIPTION = "OpenSCADA system is open implementation SCADA (Supervisory controll and data acquisition) systems"
5 HOMEPAGE = "http://oscada.org.ua/"
6 LICENSE = "GPL"
7 SECTION = "Applications"
8 DEPENDS = "gd mysql expat sqlite3 lmsensors-apps fftw qt4-x11-free"
9 #SRC_URI = "ftp://ftp.oscada.org/OpenSCADA/0.6.4/openscada-0.6.4.tar.gz"
10 SRC_URI = "svn://oscada.org.ua/trunk;module=OpenSCADA;rev=;proto=svn \
11            file://rcc-moc.patch;patch=1 \
12           "
13
14 PV = "0.6.4+svnr${SRCPV}"
15
16 S = "${WORKDIR}/OpenSCADA"
17
18 inherit autotools_stage
19
20 EXTRA_OECONF = " \
21       --includedir=${STAGING_INCDIR} \
22       --oldincludedir=${STAGING_INCDIR} \
23       --disable-SQLite \
24       --disable-MySQL \
25       --disable-FireBird \
26       --without-sqlite3 \
27       --without-firebird \
28       --disable-SoundCard \
29       --disable-Vision \
30       --disable-WebVision \
31       --disable-shared \
32 "
33
34 #do_configure_prepend() {
35 #  autoconf
36 #}
37
38 #do_configure() {
39 #  oe_runconf
40 #}
41
42
43 do_install_prepend () {
44   mkdir -p -m 755 ${D}/etc
45   cp ${S}/data/oscada.xml ${D}/etc
46   mkdir -p -m 755 ${D}/var/spool/openscada/icons
47   cp ${S}/data/icons/* ${D}/var/spool/openscada/icons
48   install -p -m 777 -d ${D}/var/spool/openscada/ARCHIVES/{MESS,VAL}
49 }
50