netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / openmoko-projects / illume-theme-asu_svn.bb
1 DESCRIPTION = "Illume - Mobile UI module for Enlightenment"
2 HOMEPAGE = "http://illume.projects.openmoko.org/"
3 LICENSE = "MIT/BSD"
4 DEPENDS = "edje-native eet-native"
5 RPROVIDES_${PN} = "illume-theme"
6 RCONFLICTS = "illume-config"
7 SRCREV = "4881"
8 PV = "0.0+svnr${SRCPV}"
9 PR = "r9"
10
11 SRC_URI = "svn://svn.openmoko.org/trunk/src/target/themes/;module=illume-theme-asu;proto=http"
12
13 S = "${WORKDIR}/illume-theme-asu"
14
15 do_compile() {
16     cd misc-data/asu && ./build.sh && cd ../..
17     cd misc-data/asu_init && ./build.sh && cd ../..
18     cd config
19     eet -e e.cfg config e.src 1
20     eet -e module.battery.cfg config module.battery.src 1
21     eet -e module.illume.cfg config module.illume.src 1
22 }
23
24 do_install() {
25     install -d ${D}${sysconfdir}/enlightenment
26     install -d ${D}${datadir}/enlightenment/data/themes
27     install -d ${D}${datadir}/enlightenment/data/init
28     install -d ${D}${datadir}/enlightenment/data/config/asu
29     # Make asu the default profile
30     echo 'E_PROFILE="-profile asu"' > ${D}${sysconfdir}/enlightenment/default_profile
31     install -m 0644 ${S}/misc-data/asu/asu.edj ${D}${datadir}/enlightenment/data/themes/asu.edj
32     install -m 0644 ${S}/misc-data/asu_init/asu_init.edj ${D}${datadir}/enlightenment/data/init/asu_init.edj
33     install -m 0644 ${S}/config/*.cfg ${D}${datadir}/enlightenment/data/config/asu
34 }
35
36 PACKAGE_ARCH_${PN} = "all"
37 PACKAGES = "\
38     ${PN} \
39 "
40 FILES_${PN} = "${sysconfdir}/enlightenment ${datadir}/enlightenment"
41
42 CONFFILES_${PN} = "${sysconfdir}/enlightenment/default_profile"