sg3-utils: add newer buildable version
[openembedded.git] / recipes / openmoko-3rdparty / podboy_svn.bb
1 DESCRIPTION = "A podcast aggregator/player"
2 HOMEPAGE = "http://code.google.com/p/podboy/"
3 LICENSE = "GPLv3"
4 AUTHOR = "ValĂ©ry Febvre <vfebvre@easter-eggs.com>"
5 SECTION = "x11/applications"
6 PRIORITY = "optional"
7
8 SRCREV = "123"
9 PV = "1.5.0+svnr${SRCPV}"
10
11 PACKAGE_ARCH = "all"
12
13 SRC_URI = "svn://podboy.googlecode.com/svn;module=trunk;proto=http"
14 S = "${WORKDIR}/trunk"
15
16 inherit distutils
17
18 FILES_${PN} += "${datadir}/podboy ${datadir}/applications/podboy.desktop ${datadir}/pixmaps/podboy.png"
19
20 RDEPENDS += "python-compression python-elementary python-gst python-html python-netclient python-netserver python-sqlite3 python-subprocess gst-plugin-alsa gst-plugin-audioconvert gst-plugin-audioresample gst-plugin-bluez gst-plugin-mad gst-plugin-ogg gst-plugin-volume gst-plugin-vorbis"
21
22 do_compile_prepend() {
23         ${STAGING_BINDIR_NATIVE}/edje_cc ${S}/data/podboy.edc
24 }