sg3-utils: add newer buildable version
[openembedded.git] / recipes / openmoko-3rdparty / openmoko-gps_0.0.1+svnr9.bb
1 #! /bin/sh
2 #
3 # Copyright Matthias Hentges <devel@hentges.net> (c) 2008
4 # License: MIT (see http://www.opensource.org/licenses/mit-license.php 
5 #               for a copy of the license)
6 #
7 # Filename: openmoko-gps_svn.bb
8 # Date: 20080101 (YMD)
9
10 DESCRIPTION = "A tiny GPS output parser for the Openmoko platform."
11 HOMEPAGE = "http://forge.bearstech.com/trac/wiki/OpenmokoGPS"
12 SECTION = "base"
13 LICENSE = "GPL"
14
15 RDEPENDS = "python-pygtk"
16
17 PR = "r0" 
18
19 ######################################################################################
20
21 SRC_URI = "svn://forge.bearstech.com/bearforge/openmoko;module=gps;rev=9"
22
23 S = "${WORKDIR}/gps"
24
25 do_install() {
26         install -d ${D}/usr/bin
27         install -d ${D}/usr/share/applications/
28         install -d ${D}/usr/share/pixmaps/
29         
30         install -m 0755 ${S}/gps_reader.py ${D}/usr/bin
31         install -m 0644 ${S}/openmoko-gps.desktop ${D}/usr/share/applications/
32         install -m 0644 ${S}/*.png ${D}/usr/share/pixmaps/
33 }