sg3-utils: add newer buildable version
[openembedded.git] / recipes / openmoko-3rdparty / neomis_svn.bb
1 DESCRIPTION = "A computer version of the well-known electronic game named Simon"
2 HOMEPAGE = "http://code.google.com/p/neomis/"
3 LICENSE = "GPLv3"
4 AUTHOR = "ValĂ©ry Febvre <vfebvre@easter-eggs.com>"
5 SECTION = "x11/applications"
6 PRIORITY = "optional"
7 DEPENDS = "python-native"
8
9 SRCREV = "6"
10 PV = "1.1.0+svnr${SRCPV}"
11 PR = "r1"
12
13 S = "${WORKDIR}/trunk"
14
15 PACKAGE_ARCH = "all"
16
17 SRC_URI = "svn://neomis.googlecode.com/svn;module=trunk;proto=http"
18
19 inherit distutils
20
21 do_configure_prepend_shr() {
22         sed -e 's,^Exec=,Exec=/usr/bin/fsoraw -r Display ,g' -i ${S}/data/neomis.desktop
23 }
24
25 FILES_${PN} += "${datadir}/neomis ${datadir}/applications/neomis.desktop ${datadir}/pixmaps"
26
27 RDEPENDS += "python-audio python-pyalsaaudio python-elementary"