0d27d0682ca6c47b14f3fdf1e99fae2b1f389756
[openembedded.git] / recipes / net-snmp / net-snmp_svn.bb
1 require net-snmp.inc
2 DEPENDS += "libtool libtool-native libtool-cross"
3 PR = "${INC_PR}.0"
4
5 S = "${WORKDIR}/net-snmp"
6
7 SRC_URI = "svn://net-snmp.svn.sourceforge.net/svnroot/net-snmp/trunk;module=net-snmp;proto=https \
8         file://init \
9         file://snmpd.conf \
10         file://snmptrapd.conf"
11
12 EXTRA_OECONF = "--enable-shared --disable-manuals --with-defaults \
13                 --disable-embedded-perl --with-perl-modules=no GREP=/bin/grep SED=/bin/sed"
14 EXTRA_OEMAKE = "INSTALL_PREFIX=${D}"
15
16 PARALLEL_MAKE = ""
17 CCACHE = ""
18
19 do_configure_prepend() {
20     gnu-configize -f
21     # We better change sources and re-autoconf here, but
22     # required autoconf is too new for us.
23     sed -e '/echo.*\".*\\\\.*\"/s/echo/echo -e/g' \
24         -e 's/tail -1/tail -n 1/g'                \
25         -i configure
26 }
27