abiword: add 2.8.3
[openembedded.git] / recipes / nautilus / nautilus_2.30.0.bb
1 # nautilus OE build file
2 # Copyright (C) 2005, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 inherit gnome
6
7 SRC_URI += "file://idl-sysroot.patch;patch=1 \
8             file://no-try-run-strftime.diff;patch=1 \
9 "
10
11 SRC_URI[archive.md5sum] = "e09aea66166c0a90d09955bd4d2672be"
12 SRC_URI[archive.sha256sum] = "01ecbc4b8b9a0ac726194eb81d3de7080ee52d885eb1898692aa951b093731a5"
13
14 export SYSROOT = "${STAGING_DIR_HOST}"
15
16 LICENSE="GPL"
17
18 DEPENDS += "libunique  gvfs tracker librsvg libexif esound gnome-desktop orbit2-native"
19 RDEPENDS = "gvfs gvfsd-ftp gvfsd-sftp gvfsd-trash"
20
21 EXTRA_OECONF = " --disable-gtk-doc  --disable-update-mimedb "
22
23 PACKAGES += " libnautilus"
24
25 FILES_${PN} += "${datadir}/icons  /usr/libexec/ "
26 FILES_libnautilus = "/usr/lib/*.so*"
27 FILES_${PN}-dbg += "/usr/libexec/.debug"
28
29 do_configure_prepend() {
30         sed -i -e /docs/d Makefile.am
31 }
32
33 # We need native orbit-idl with target idl files. No way to say it in a clean way:
34 do_configure_append () {
35         find -name Makefile -exec sed -i '/\/usr\/bin\/orbit-idl-2/{s:/usr/bin:${STAGING_BINDIR_NATIVE}:;s:/usr/share:${STAGING_DATADIR}:g}' {} \;
36 }
37