netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / mutt / mutt_1.5.4i.bb
1 SECTION = "console/network"
2 DEPENDS = "ncurses openssl"
3 DESCRIPTION = "Mutt is a small but very powerful text-based \
4 MIME mail client. It is highly configurable, and is well-suited \
5 to the mail power user with advanced features like key \
6 bindings, keyboard macros, mail threading, regular expression \
7 searches, and a powerful pattern matching language for selecting \
8 groups of messages."
9 LICENSE = "GPL"
10 PR = "r1"
11 SRC_URI = "ftp://ftp.mutt.org/mutt/devel/mutt-${PV}.tar.gz \
12            http://mutt.kiev.ua/download/mutt-1.5.4/patch-1.5.4.rr.compressed.gz;patch=1 \
13            http://mutt.kiev.ua/download/mutt-1.5.4/patch-1.5.4.vvv.nntp.gz;patch=1 \
14            http://mutt.kiev.ua/download/mutt-1.5.4/patch-1.5.4.vvv.initials.gz;patch=1 \
15            http://mutt.kiev.ua/download/mutt-1.5.4/patch-1.5.4.vvv.quote.gz;patch=1 \
16            file://cppflags.patch;patch=1 \
17            file://posix1_lim.patch;patch=1 \
18            file://keymap.h.patch;patch=1 \
19            file://configure.patch;patch=1"
20 S = "${WORKDIR}/mutt-1.5.4"
21
22 inherit autotools
23
24 EXTRA_OECONF = "--disable-pgp --without-mixmaster --with-curses=${STAGING_LIBDIR}/.. \
25                 --enable-pop --enable-imap --with-ssl --enable-compressed --enable-nntp"
26
27 do_compile_prepend () {
28         ${BUILD_CC} makedoc.c -o makedoc
29 }