netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / mozilla / firefox_3.0.8.bb
1 DEPENDS += "cairo"
2 PR = "r1"
3
4 # Fails to build with gcc 4.3.x due to wchar problems:
5 # /OE/angstrom-dev/cross/armv7a/lib/gcc/arm-angstrom-linux-gnueabi/4.3.1/../../../../arm-angstrom-linux-gnueabi/bin/ld: ERROR: mozilla-xremote-client.o: Conflicting definitions of wchar_t
6 DEFAULT_PREFERENCE = "-1"
7
8 SRC_URI = "ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}-source.tar.bz2 \
9         file://jsautocfg.h \
10         file://security-cross.patch;patch=1 \
11         file://jsautocfg-dontoverwrite.patch;patch=1 \
12         file://Bug339782.additional.fix.diff;patch=1 \
13         file://Bug385583.nspr.jmp_buf.eabi.diff;patch=1 \
14         file://Bug405992.atomic.nspr.diff;patch=1 \
15         file://jemalloc-tls.patch;patch=1 \
16         file://0001-Remove-Werror-from-build.patch;patch=1 \
17         file://0002-Fix-security-cross-compile-cpu-detection-error.patch;patch=1 \
18         file://plugins-dir.patch;patch=1 \
19 "
20
21 S = "${WORKDIR}/mozilla"
22
23 inherit mozilla
24 require firefox.inc
25
26 FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
27
28 do_compile_prepend() {
29         cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
30         sed -i "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" security/coreconf/Linux.mk
31 }
32
33 do_stage() {
34         install -d ${STAGING_INCDIR}/firefox-${PV}
35         cd dist/sdk/include
36                 rm -rf obsolete
37         headers=`find . -name "*.h"`
38         for f in $headers
39         do
40                 install -D -m 0644 $f ${STAGING_INCDIR}/firefox-${PV}/
41         done
42         # removes 2 lines that call absent headers
43         sed -e '178,179d' ${STAGING_INCDIR}/firefox-${PV}/nsIServiceManager.h
44 }