abiword: add 2.8.3
[openembedded.git] / recipes / mozilla / firefox_3.0.4.bb
1 DEPENDS += "cairo"
2 PR = "r1"
3
4 SRC_URI = "ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}-source.tar.bz2 \
5         file://jsautocfg.h \
6         file://security-cross.patch;patch=1 \
7         file://jsautocfg-dontoverwrite.patch;patch=1 \
8         file://Bug339782.additional.fix.diff;patch=1 \
9         file://Bug385583.nspr.jmp_buf.eabi.diff;patch=1 \
10         file://Bug405992.atomic.nspr.diff;patch=1 \
11         file://random_to_urandom.diff;patch=1 \
12         file://jemalloc-tls.patch;patch=1 \
13         file://0001-Remove-Werror-from-build.patch;patch=1 \
14         file://0002-Fix-security-cross-compile-cpu-detection-error.patch;patch=1 \
15         file://plugins-dir.patch;patch=1 \
16 "
17
18 S = "${WORKDIR}/mozilla"
19
20 # This is missing the wchart.diff patch and can't be compiled with a recent gcc
21 DEFAULT_PREFERENCE = "-1"
22
23 inherit mozilla
24 require firefox.inc
25
26 FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
27
28 do_compile_prepend() {
29         cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
30         sed -i "s|CPU_ARCH =|CPU_ARCH = ${TARGET_ARCH}|" security/coreconf/Linux.mk
31 }
32
33 do_stage() {
34         install -d ${STAGING_INCDIR}/firefox-${PV}
35         cd dist/sdk/include
36                 rm -rf obsolete
37         headers=`find . -name "*.h"`
38         for f in $headers
39         do
40                 install -D -m 0644 $f ${STAGING_INCDIR}/firefox-${PV}/
41         done
42         # removes 2 lines that call absent headers
43         sed -e '178,179d' ${STAGING_INCDIR}/firefox-${PV}/nsIServiceManager.h
44 }