sane-srcrevs: move SRCREVs to recipes
[openembedded.git] / recipes / matchbox2 / matchbox-panel-2-icon-themes_0.0.1.bb
1 DESCRIPTION = "icon theme for matchbox-panel-2"
2 LICENSE = "GPLv2"
3 SECTION = "x11/panels"
4 DEPENDS = "imagemagick-native"
5 RPROVIDES_${PN} = "matchbox-panel-2-icon-theme"
6 PACKAGE_ARCH = "all"
7 SRCREV_FORMAT = "startup"
8 SRCREV = "1907"
9 PV = "0.0.1+svnr${SRCPV}"
10 PR = "r0"
11
12 inherit gtk-icon-cache
13
14 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-panel-2/applets/battery/data;proto=http;maxrev=1918 \
15            svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-panel-2/applets/startup/data;proto=http;name=startup \
16            svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-panel-2/applets/brightness/data;proto=http \
17            file://user-desktop.png \
18            file://task-switcher.png \
19 "
20 S = "${WORKDIR}"
21
22 do_install() {
23         cd ${S}
24         mkdir -p ${D}${datadir}/icons/HighContrast/48x48/status ${D}${datadir}/icons/HighContrastInverse/48x48/status
25         install -m 0644 matchbox-panel-2/applets/battery/data/*.png ${D}${datadir}/icons/HighContrastInverse/48x48/status/
26         mkdir -p ${D}${datadir}/icons/HighContrast/32x32/status ${D}${datadir}/icons/HighContrastInverse/32x32/status
27         install -m 0644 matchbox-panel-2/applets/brightness/data/*.png ${D}${datadir}/icons/HighContrastInverse/32x32/status/
28         mkdir -p ${D}${datadir}/icons/HighContrast/32x32/animations ${D}${datadir}/icons/HighContrastInverse/32x32/animations
29         install -m 0644 matchbox-panel-2/applets/startup/data/*.png ${D}${datadir}/icons/HighContrastInverse/32x32/animations/
30         cd ${D}${datadir}/icons/HighContrastInverse
31         for PNG in */*/*.png ; do
32                 convert -negate $PNG ../HighContrast/$PNG
33         done
34         cd ${S}
35         mkdir -p ${D}${datadir}/icons/HighContrast/32x32/apps ${D}${datadir}/icons/HighContrastInverse/32x32/apps
36         install -m 0644 user-desktop.png task-switcher.png ${D}${datadir}/icons/HighContrast/32x32/apps/
37         cd ${D}${datadir}/icons/HighContrast
38         for PNG in 32x32/apps/*.png ; do
39                 convert -negate $PNG ../HighContrastInverse/$PNG
40         done
41         cd ${S}
42
43         # FIXME: The default vendor provided theme uses "white on
44         # transparent" style and it is invisible with the default GTK+
45         # style. We need a better solution for fallback icons and dark
46         # themes. For now, define only "black on transparent" as
47         # hicolor. It is still pretty ugly: Hicolor is expected to be
48         # hicolor, makes icons invisible in dark themes.
49         rm -r ${D}${datadir}/icons/HighContrastInverse
50         mv ${D}${datadir}/icons/HighContrast ${D}${datadir}/icons/hicolor
51 }
52
53 FILES_${PN} += "${datadir}/icons/*"