netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / matchbox-wm / matchbox-wm_0.9.5.bb
1 require matchbox-wm.inc
2
3 DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes libxdamage libxrender startup-notification expat gconf "
4 RDEPENDS = ""
5 PR ="r2"
6
7 SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/0.9/matchbox-window-manager-${PV}.tar.gz \
8            file://kbdconfig"
9
10 S = "${WORKDIR}/matchbox-window-manager-${PV}"
11
12 inherit autotools pkgconfig update-alternatives
13
14 FILES_${PN} = "${bindir}/* \
15                ${datadir}/matchbox \
16                ${sysconfdir}/matchbox \
17                ${datadir}/themes/blondie/matchbox \
18                ${datadir}/themes/Default/matchbox \
19                ${datadir}/themes/MBOpus/matchbox"
20
21 ALTERNATIVE_NAME = "x-window-manager"
22 ALTERNATIVE_LINK = "${bindir}/x-window-manager"
23 ALTERNATIVE_PATH = "${bindir}/matchbox-session"
24 ALTERNATIVE_PRIORITY = "10"
25
26 EXTRA_OECONF = " --enable-startup-notification --disable-xrm"
27
28 do_install_prepend() {
29         install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
30 }
31