sg3-utils: add newer buildable version
[openembedded.git] / recipes / masqmail / masqmail_0.2.21.bb
1 DESCRIPTION = "MasqMail is a mail server designed for hosts that do not have \
2 a permanent internet connection eg. a home network or a single host at home. \
3 It has special support for connections to different ISPs. It replaces sendmail \
4 or other MTAs such as qmail or exim."
5 HOMEPAGE = "http://innominate.org/kurth/masqmail/"
6 SECTION = "console/network"
7 PRIORITY = "optional"
8 LICENSE = "GPL"
9 DEPENDS = "glib-2.0"
10
11 SRC_URI = "${DEBIAN_MIRROR}/main/m/${PN}/${PN}_${PV}.orig.tar.gz"
12
13 inherit autotools pkgconfig
14
15 EXTRA_OECONF += "--disable-glibtest"
16 EXTRA_OECONF += "--disable-resolver"
17
18 # These are the standard Debian values for ownership of the programs,
19 # this stuff fakes out the install script chown operations then replicates
20 # them by setting the ipkg owner/group to the desired values - everything
21 # ends up owned by the nominated user.
22 MAIL_USER ?= "mail"
23 MAIL_GROUP ?= "mail"
24
25 EXTRA_OECONF += "--with-user=$(id -u)"
26 EXTRA_OECONF += "--with-group=$(id -g)"
27
28 IPKGBUILDCMD = "ipkg-build -o ${MAIL_USER} -g ${MAIL_GROUP}"