sane-srcrevs: move SRCREVs to recipes
[openembedded.git] / recipes / llvm / llvm-gcc4-cross_svn.bb
1 DESCRIPTION = "The Low Level Virtual Machine - gcc4 frontend"
2 HOMEPAGE = "http://llvm.org"
3 LICENSE = "various"
4
5 DEPENDS = "llvm2.5-native"
6
7 SRCREV = "374"
8 PV = "2.1+svnr${SRCPV}"
9
10 PR = "r1"
11
12 inherit autotools cross
13
14 SRC_URI = "svn://anonsvn.opensource.apple.com/svn/llvm/;module=trunk \
15            "
16            
17 S = "${WORKDIR}/trunk"
18
19 EXTRA_OECONF = "--disable-shared \
20                 --enable-llvm=/data/build/koen/OE/build/tmp/angstrom/work/i686-linux/llvm-native-2.0-r0/llvm-2.0 \
21                "
22
23 do_configure() {
24         gnu-configize
25         libtoolize --force
26         oe_runconf
27 }       
28
29 PARALLEL_MAKE = ""
30
31 #oe_runmake gets distracted by GNUMakefiles...
32 # we also need to get an install.sh and config-ml.in in gcc/ as well somehow
33 do_compile_prepend() {
34         rm -f ${S}/GNUmakefile
35 }