netboot-launcher-efl: Bump version to 0.2.2 and fix download link.
[openembedded.git] / recipes / linux-libc-headers / linux-libc-headers_2.6.18.bb
1 require linux-libc-headers.inc
2
3 INHIBIT_DEFAULT_DEPS = "1"
4 DEPENDS += "unifdef-native"
5 PR = "r4"
6
7 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2 \
8            file://arm-syscall-define.patch;patch=1"
9
10 S = "${WORKDIR}/linux-2.6.18"
11
12 set_arch() {
13         case ${TARGET_ARCH} in
14                 alpha*)   ARCH=alpha ;;
15                 arm*)     ARCH=arm ;;
16                 cris*)    ARCH=cris ;;
17                 hppa*)    ARCH=parisc ;;
18                 i*86*)    ARCH=i386 ;;
19                 ia64*)    ARCH=ia64 ;;
20                 mips*)    ARCH=mips ;;
21                 m68k*)    ARCH=m68k ;;
22                 powerpc*) ARCH=powerpc ;;
23                 s390*)    ARCH=s390 ;;
24                 sh*)      ARCH=sh ;;
25                 sparc64*) ARCH=sparc64 ;;
26                 sparc*)   ARCH=sparc ;;
27                 x86_64*)  ARCH=x86_64 ;;
28         esac
29 }
30
31 do_configure() {
32         set_arch
33         oe_runmake allnoconfig ARCH=${ARCH}
34 }
35
36 do_compile () {
37 }
38
39 do_install() {
40         set_arch
41         oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=${ARCH}
42         # Add UTS_RELEASE to version.h. UTS_RELEASE was moved from version.h to
43         # utsrelease.h in order to avoid recompiling a kernel every time a localversion
44         # changed. Since the our headers are static and we're not compiling an
45         # actual kernel, re-adding UTS_RELEASE does't hurt, and it allows uclibc to
46         # compile with kernel headers that work with EABI on ARM
47         echo '#define UTS_RELEASE "2.6.18"' >> ${STAGING_INCDIR}/linux/version.h
48 }
49
50 do_install_append_arm() {
51         cp include/asm-arm/procinfo.h ${D}${includedir}/asm
52 }