abiword: add 2.8.3
[openembedded.git] / recipes / linux / linux-palm-omap1_2.6.22-omap1.bb
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for OMAP1-based Palm devicess"
3 LICENSE = "GPLv2"
4
5 COMPATIBLE_MACHINE = "(palmz71|palmtt|palmtt2)"
6
7 inherit kernel
8
9 DEPENDS = ""
10
11 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.22.tar.bz2 \
12            http://www.muru.com/linux/omap/patches/patch-2.6.22-omap1.bz2;patch=1 \
13            file://defconfig"
14
15 S = "${WORKDIR}/linux-2.6.22"
16
17 PR = "r2"
18
19 do_configure() {
20
21         if [ -f ${WORKDIR}/defconfig ]; then
22                 install -m 0644 ${WORKDIR}/defconfig ${S}/.config || die "No configuration for ${MACHINE} available."
23         else
24                 die "No configuration for ${MACHINE} available."
25         fi
26         
27
28         if [ "${TARGET_OS}" == "linux-gnueabi" -o  "${TARGET_OS}" == "linux-uclibceabi" ]; then
29                 echo "CONFIG_AEABI=y"                   >> ${S}/.config
30                 echo "CONFIG_OABI_COMPAT=y"             >> ${S}/.config
31         else
32                 echo "# CONFIG_AEABI is not set"        >> ${S}/.config
33                 echo "# CONFIG_OABI_COMPAT is not set"  >> ${S}/.config
34         fi
35         yes '' | oe_runmake oldconfig
36
37 }