abiword: add 2.8.3
[openembedded.git] / recipes / linux / linux-kirkwood_2.6.33-rc1.bb
1 DESCRIPTION = "Linux Kernel for Marvell Kirkwood based devices"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
4
5 COMPATIBLE_MACHINE = "openrd-base|openrd-client|sheevaplug"
6
7 require linux.inc
8
9 # Change MACHINE_KERNEL_PR in conf/machine/include/kirkwood.inc
10 PV = "2.6.32+2.6.33-rc1"
11
12 SRCREV = "58c19e3ea75a629c3d38a4490f96a65cf2f36a11"
13
14 SRC_URI = "git://repo.or.cz/linux-2.6/linux-2.6-openrd.git;protocol=git \
15            file://defconfig"
16
17 SRC_URI_append_openrd-base += " \
18          file://openrd-base/openrd-base-enable-pcie.patch;patch=1 \
19          file://0004-ARM-Kirkwood-OpenRD-SD-UART1-selection.patch;patch=1 \
20         "
21
22 SRC_URI_append_openrd-client += " \
23          file://0001-OpenRD-Client-PCIe-Initialize-PCI-express-and-i2c.patch;patch=1 \
24          file://0002-OpenRD-Client-Volari-Z11-driver-added.patch;patch=1 \
25          file://0003-ARM-Kirkwood-Sound-Sound-driver-added.patch;patch=1 \
26          file://0004-ARM-Kirkwood-OpenRD-SD-UART1-selection.patch;patch=1 \
27         "
28
29 # update machine types list for ARM architecture, only for machines that need it
30 do_arm_mach_types() {
31 #  if test ${MACHINE} == openrd-base || test ${MACHINE} == openrd-client; then
32     curl -o mach-types "http://www.arm.linux.org.uk/developer/machines/download.php" && \
33     cp mach-types arch/arm/tools/mach-types
34 #  fi
35 }
36
37 addtask arm_mach_types after do_patch before do_configure
38
39 S = "${WORKDIR}/git"
40
41 KERNEL_IMAGETYPE ?= "uImage"
42