sane-srcrevs: move SRCREVs to recipes
[openembedded.git] / recipes / libxosd / libxosd_svn.bb
1 DESCRIPTION = "A library for displaying a TV-like on-screen display in X."
2 SECTION = "libs/x11"
3 DEPENDS = "virtual/libx11 libxext"
4 LICENSE = "LGPL"
5 SRCREV = "627"
6 PV = "2.2.15+svnr${SRCPV}"
7 PR = "r5"
8
9 SRC_URI = "svn://libxosd.svn.sourceforge.net/svnroot/libxosd/source;module=current;proto=https \
10            file://autofoo.patch;patch=1 \
11            file://use-sane-default-font.patch;patch=1"
12
13 S = "${WORKDIR}/current"
14
15 inherit autotools binconfig
16
17 do_stage() {
18         autotools_stage_all
19 }
20
21 PACKAGES =+ "${PN}-examples-dbg ${PN}-examples"
22 FILES_${PN}-examples = "${bindir}/osd_cat"
23 FILES_${PN}-examples-dbg += "${bindir}/.debug/"
24 FILES_${PN}-dev += "${bindir}/xosd-config"
25 FILES_${PN} = "${libdir}/libxosd.so.*"