libtool_2.2.6b.bb : new version of libtool
[openembedded.git] / recipes / libtool / libtool-cross_2.2.6b.bb
1 require libtool_${PV}.bb
2 PR = "${INC_PR}.0"
3
4 SRC_URI += "\
5   file://cross_compile.patch;patch=1 \
6   file://prefix.patch;patch=1 \
7 "
8
9 DEPENDS += "libtool-native"
10
11 DOLT_PATCH = ""
12 DOLT_PATCH_arm = " file://add_dolt.patch;patch=1"
13 DOLT_PATCH_i586 = " file://add_dolt.patch;patch=1"
14
15 #SRC_URI_append_linux = "${DOLT_PATCH}"
16 #SRC_URI_append_linux-gnueabi = "${DOLT_PATCH}"
17
18 prefix = "${STAGING_DIR_NATIVE}${prefix_native}"
19 exec_prefix = "${STAGING_DIR_NATIVE}${prefix_native}"
20 bindir = "${STAGING_BINDIR_NATIVE}"
21
22 do_compile () {
23         :
24 }
25
26 do_stage () {
27         install -m 0755 ${HOST_SYS}-libtool ${bindir}/${HOST_SYS}-libtool
28         install -d ${STAGING_DIR_HOST}${target_datadir}/libtool ${STAGING_DIR_HOST}${target_datadir}/aclocal
29         install -c ${S}/libltdl/config/config.guess ${STAGING_DIR_HOST}${target_datadir}/libtool/
30         install -c ${S}/libltdl/config/config.sub ${STAGING_DIR_HOST}${target_datadir}/libtool/
31         install -c -m 0644 ${S}/libltdl/config/ltmain.sh ${STAGING_DIR_HOST}${target_datadir}/libtool/
32         install -c -m 0644 ${S}/libltdl/m4/libtool.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
33         install -c -m 0644 ${S}/libltdl/m4/ltdl.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
34         if [ -e ${WORKDIR}/dolt.m4 ] ; then
35                 install -c -m 0644 ${WORKDIR}/dolt.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
36         fi
37 }
38
39
40 do_install () {
41         :
42 }
43
44 PACKAGES = ""