libsdl-directfb: use the options of our patched autoreconf, to prevent autoheader
[openembedded.git] / recipes / libsdl / libsdl-directfb_1.2.14.bb
1 DESCRIPTION = "Simple DirectMedia Layer (DirectFB and Framebuffer support)"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 LICENSE = "LGPL"
5 DEPENDS = "alsa-lib directfb"
6 PROVIDES = "virtual/libsdl"
7
8 SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz"
9 SRC_URI[md5sum] = "e52086d1b508fa0b76c52ee30b55bec4"
10 SRC_URI[sha256sum] = "5d927e287034cb6bb0ebccfa382cb1d185cb113c8ab5115a0759798642eed9b6"
11
12 S = "${WORKDIR}/SDL-${PV}"
13
14 inherit autotools lib_package binconfig pkgconfig
15
16 EXTRA_OECONF = " \
17         --disable-arts \
18         --disable-diskaudio \
19         --disable-esd \
20         --disable-esd-shared \
21         --disable-esdtest \
22         --enable-input-events \
23         --disable-input-tslib \
24         --disable-mintaudio \
25         --disable-nas \
26         --disable-nasm \
27         --disable-video-dga \
28         --disable-video-dummy \
29         --enable-video-directfb \
30         --enable-video-fbcon \
31         --disable-video-opengl \
32         --disable-video-picogui \
33         --disable-video-ps2gs \
34         --disable-video-ps3 \
35         --disable-video-qtopia \
36         --disable-video-x11 \
37 "
38 EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
39
40 do_configure_prepend () {
41         # Remove old libtool macros.
42         MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
43         for i in ${MACROS}; do
44                rm acinclude/$i
45         done
46 }